It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey guys, dev here,

Sorry that you're all running into this issue. We're currently looking into what is causing this (as it's not happening for everyone, although a lot of people are reporting issues). Thanks for reporting the issue! I'll report back when we know more, and sorry again for the inconvencience!
Post edited June 19, 2018 by killersponge
We've found the issue: a settings file that is not correctly deployed the first time. We're making a new build ASAP, but as a temporary solution you can put this in you settings.ini file in Documents/Renowned Explorers International Society/userdata

r_fontgamma = 1.200000
r_uselcdfilter = true
r_renderConfig = "rendering\/renderer"

That should fix the issue. Again, sorry for the hassle!
New build (489.1) should be up now. If anyone runs into any other issues, please let me know here or at :)
After updating to the new build it's working fine for me now. Thanks for the quick response!
Thanks for your reactivity!
Yey the new build is working, GG! :D
Yep, it is working again. Thx for fixing the issue. I just love this game it is one of few games that I am coming back to play ^_^