It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
JiminyJickers: Yeah, I tried turning off all settings, tried Windowed, Full Screen, and Windowed Fullscreen on DirectX 9, OpenGL, and DirectX 11. Same message every time.
avatar
JudasIscariot: I made a sticky for you and anyone else having trouble with the game to post your "Ogre.log" files in so that we can collect them and get them forwarded to the devs :) Please post your log :)
Okay, thank you. I will post it shortly.
avatar
JudasIscariot: Have you tried tweaking any options within the Launcher? Tried playing the game with the DirectX 9 Renderer? Not sure what's going on here as you have all the redistributables and more than likely you have DirectX 11 installed.
avatar
JiminyJickers: Yeah, I tried turning off all settings, tried Windowed, Full Screen, and Windowed Fullscreen on DirectX 9, OpenGL, and DirectX 11. Same message every time.
Also, can you tell me whether you installed the game via Galaxy or the offline installer? And if you've tried via Galaxy, can you uninstall the game and install it via the offline installer, it it's not too much trouble?
avatar
JiminyJickers: Yeah, I tried turning off all settings, tried Windowed, Full Screen, and Windowed Fullscreen on DirectX 9, OpenGL, and DirectX 11. Same message every time.
avatar
JudasIscariot: Also, can you tell me whether you installed the game via Galaxy or the offline installer? And if you've tried via Galaxy, can you uninstall the game and install it via the offline installer, it it's not too much trouble?
Okay I solved the problem, thanks to your hint about Galaxy. The GalaxyPeer.dll file in the game directory is causing the problem, after I deleted it, the game starts fine.

As for Galaxy, I have only used the Offline installer. I have Galaxy installed but am not using it.
Post edited October 22, 2015 by JiminyJickers
avatar
bigdog002: Windows 10, GTX 560ti, 16 gigs ram, latest NVidia driver.

Crashes immediately after hitting run. Tried every combination of settings, same result.

I'd really like to play this game, may have to wait for the console version. I requested money back but if anyone has suggestions I can try let me know. Thanks.
I am running a system that is technically below minimum requirements
Dell latitude e5500 ( Vista Vintage) Intel Duo T7250 2.0 GHZ. 4Gb Memory. No GPU
windows 10 insider pro builds

I am using a Xbox for windows PC controller

Default Startup settings except for Shadowing set to LOW and
Effect Quality set to Low.

I followed Jimmy Jickers suggestion about deleting GalaxyPeer.dll in another thread
I renamed it hide-GalaxyPeer.dll
I found it in:
C:GOG Games\Rebel Galaxy\

This seems to have solved the crash issue for me.

Good luck hope this helps you also.
Thought it may be related, so I'm posting here instead of starting a new thread.

Seems to me Rebel Galaxy 'phones home' each time I start it up.
If I set my firewall to allow the connection, game runs fine.
If I deny, it crashes.

Why/where does it try to connect to, and how do I stop it from doing it without crashing?

Win7 64-bit.
delete this
Post edited June 23, 2017 by ussnorway
I ran it using direct x9 and it worked after that.