It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Windows 10, GTX 560ti, 16 gigs ram, latest NVidia driver.

Crashes immediately after hitting run. Tried every combination of settings, same result.

I'd really like to play this game, may have to wait for the console version. I requested money back but if anyone has suggestions I can try let me know. Thanks.
Same here, game crashes at startup, tried all possible video settings combinations.

W7, GTX760, 8gb ram, i5 4670.
EDIT:

Rename or Delete GalaxyPeer.dll from the game directory. It solved it for me.
Post edited October 22, 2015 by JiminyJickers
I bet its a Gforce problem my AMD based PC is running it just fine.

R9270x 2gb
Win 7 64bit
16gb ram
AMD Phenom II X4 3.2ghz
GTX 660Ti here, runs just fine.

Might check with the Steam forum for the game, the developers are using it for the official forum. You might also check the game profile folder for crash logs.
avatar
JiminyJickers: Same here, immediately crashes.

Windows 7 64-bit, GTX 980
Is this with Nvidia driver version 358.50?

Also, do you get any error messages when it crashes?
Post edited October 21, 2015 by JudasIscariot
avatar
JiminyJickers: Same here, immediately crashes.

Windows 7 64-bit, GTX 980
avatar
JudasIscariot: Is this with Nvidia driver version 358.50?

Also, do you get any error messages when it crashes?
Just the 'windows encountered a problem searching for solution" BS then right back to desktop.

Tried disabling AV, didn't help. Still an immediate crash after hitting 'run'.
avatar
JiminyJickers: Same here, immediately crashes.

Windows 7 64-bit, GTX 980
avatar
JudasIscariot: Is this with Nvidia driver version 358.50?

Also, do you get any error messages when it crashes?
Yes, I am running that driver version.

The crash message is just Windows have encountered an error. It blames MSVCR110.dll.
avatar
JudasIscariot: Is this with Nvidia driver version 358.50?

Also, do you get any error messages when it crashes?
avatar
JiminyJickers: Yes, I am running that driver version.

The crash message is just Windows have encountered an error. It blames MSVCR110.dll.
Download and run the Visual C++ 2012 Update 4 runtime.

http://www.microsoft.com/en-us/download/details.aspx?id=30679

Let me know if that helps :)
avatar
JiminyJickers: Yes, I am running that driver version.

The crash message is just Windows have encountered an error. It blames MSVCR110.dll.
avatar
JudasIscariot: Download and run the Visual C++ 2012 Update 4 runtime.

http://www.microsoft.com/en-us/download/details.aspx?id=30679

Let me know if that helps :)
Unfortunately, that didn't help. Still the same crash.
avatar
JudasIscariot: Download and run the Visual C++ 2012 Update 4 runtime.

http://www.microsoft.com/en-us/download/details.aspx?id=30679

Let me know if that helps :)
avatar
JiminyJickers: Unfortunately, that didn't help. Still the same crash.
And you downloaded the 64-bit version? Sorry for the obvious question but I can't read minds and all :)
avatar
JiminyJickers: Unfortunately, that didn't help. Still the same crash.
avatar
JudasIscariot: And you downloaded the 64-bit version? Sorry for the obvious question but I can't read minds and all :)
No, sorry I should have said. I downloaded and installed both 64-bit and 32-bit versions. They were already installed so I did a repair on both and then restarted the system.
avatar
JudasIscariot: And you downloaded the 64-bit version? Sorry for the obvious question but I can't read minds and all :)
avatar
JiminyJickers: No, sorry I should have said. I downloaded and installed both 64-bit and 32-bit versions. They were already installed so I did a repair on both and then restarted the system.
Have you tried tweaking any options within the Launcher? Tried playing the game with the DirectX 9 Renderer? Not sure what's going on here as you have all the redistributables and more than likely you have DirectX 11 installed.
avatar
JiminyJickers: No, sorry I should have said. I downloaded and installed both 64-bit and 32-bit versions. They were already installed so I did a repair on both and then restarted the system.
avatar
JudasIscariot: Have you tried tweaking any options within the Launcher? Tried playing the game with the DirectX 9 Renderer? Not sure what's going on here as you have all the redistributables and more than likely you have DirectX 11 installed.
Yeah, I tried turning off all settings, tried Windowed, Full Screen, and Windowed Fullscreen on DirectX 9, OpenGL, and DirectX 11. Same message every time.
avatar
JudasIscariot: Have you tried tweaking any options within the Launcher? Tried playing the game with the DirectX 9 Renderer? Not sure what's going on here as you have all the redistributables and more than likely you have DirectX 11 installed.
avatar
JiminyJickers: Yeah, I tried turning off all settings, tried Windowed, Full Screen, and Windowed Fullscreen on DirectX 9, OpenGL, and DirectX 11. Same message every time.
I made a sticky for you and anyone else having trouble with the game to post your "Ogre.log" files in so that we can collect them and get them forwarded to the devs :) Please post your log :)