It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi, I am at Chapter 16 - The Gate where you have to complete the graveyard maze and find your way back to the sheol mantlestone.

I did the jump across to the right to then find the dragon sword and the shrive behind the shimmering gate.

However, when I step on the sheol mantlestone it still says "doesn't work".

I have noticed that both the Egyptian Masks have disappeared from my inventory -- I had both of them in the graveyard maze but as soon as I arrived back at the tower domain both masks are missing.

I checked the various walkthroughs and they all just say "now that you have the shrive and dragon sword step on the sheol mantlestone which will take you to the sheol archway where you speak to Abbaddon"...but it doesn't work for me :(

Many thanks
Attachments:
sheol.png (119 Kb)
No posts in this topic were marked as the solution yet. If you can help, add your reply
I found a workaround solution.

I "solved" it by using another user's save games to replay the level I was at and it worked.

Having compared their save game with mine I found that the Egyptian masks are "missing" in both and that the only difference was that in my game save a green crystal was missing.

This green crystal is one of the needed objects to activate the Sheol portal stone (together with the shrive and dragon sword).

I did pick up this crystal but must have lost it at some point in the game, either through an action or a glitch