It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've just installed Rayman 3,but the game won't launch. Whenever I try,the screen turns black and returns me immediately to the desktop,saying that Rayman 3 had to be closed. I have Win7 32 bit with an AMD Radeon HD 6900 Series graphic card. It's odd: I've also installed the other rayman games and those run without a hitch. By the way, the R3_Setup_DX8 file shows my graphic card and the Textures Quality,but the Available Modes rectangle is completely blank and without any possible option. It would be a shame if I couldn't play this game because of my graphic card. Has this happened to anyone?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Try to launch the game in compatibility mode. Right click on the icon, properties, compatibility and choose windows xp sp3. If still doesn't working, run it as an administrator - right click "run as...".
Another tip is download the lastest driver for you video card.
Thanks for your help,Sydius,but I've already tried that. Neither the driver download nor compatibility mode made any difference. The game still closes instantly.
Your graphic card is good enought to run the game ( i get it with a gef4mx440...) so that isn't the problem.
Some other tips:
-Try to reinstall the game. I think that you performed all the integrity checks, so your download isn't corrupted.
-Disable UAC. Sometimes UAC (the pop-up box which comes up after you opened an exe) causes errors like this. To do this, navigate to Control panel -> User accounts and family safety -> User accounts -> User accounts control. Then you will see a slide, move the slider to the bottom, click ok, then restart your computer. After the restart i think it will working, but if is not, then move the slider back where it was before the modification - a little extra protection always helpful.
Just tried what you said. It didn't work. UAC isn't the problem.
You could try locating the C:\Windows\Ubisoft\ubi.ini file and modify it with notepad.
There you can manually set the resolution mode and so forth.

I recommend moving it to your desktop, edit it there and move it back, as you cannot directly save to a windows folder with notepad.

My resolution field in there looks like this for example: Gli_Mode=1 - 1920 x 1080 x 32
Thanks,Demens. But it didn't work. I've just tried this game on a friend's computer(Win 7 64 bit with an Nvidia Geforce graphic card). The game didn't run right after I installed the game in his computer. I had to run the R3_setup_DX8 file and set the resolution at Available Modes. It had several resolutions available,unlike the one on my computer,which only shows AMD Radeon as the graphic adapter and shows no possible resolutions. Even the ubi.ini file didn't work. It started with Gli_Mode=1 -0 X 0 X 0(no value). But no matter how I adjusted it,it didn't work.
Rayman 3 doesn't work on my PC (Windows 7 64 bits). "R3_Setup_DX8" and "Rayman3.exe" don't launch. Any help?

P.D. Sorry for my bad english.
Same here, when I launch Rayman 3 nothing happens. I can see the process in task manager for about a second before it goes away again.
Same is happening to me.
The .exe launches (you can watch it in the processes tab of the Task Manager) but closes about 2 seconds later.

Edit: I messed around with the configuration .exe which was included in the install, and now the game launches, it plays the Ubisoft logo, and then the game crashes to desktop after that.
Post edited December 12, 2011 by WhisperIneffable
Same here! What the hell!
I also sometimes experience this problem, but I was able to fix it.
To all having troubles, try downloading this zip archive (open the page and click the arrow to download), and extracting the contents to the folder you installed the game into (make sure that d3d8.dll is in the same folder as Rayman3.exe). Hopefully this will work for all of you, as well as me.
Post edited July 05, 2014 by RibShark
when i try to launch the game, nothing happends. it runs for about 2 secs, but only in the task manager.

i have tried all the previously listed fixes for the game.

i'm running windows 10, 64 bit. if it matters, i've got a GTX 970m graphics card and it's an MSI laptop.

Just had the same problem with Rayman 3 not launching on Windows 10 AU x64.

Problem fixed by installing Microsoft's (legacy) DirectPlay library.

You can do that via Windows: "Programs and Features" >> "Turn Windows features on or off" >> "Legacy Components" >> "DirectPlay".

Game runs without any problems after doing this.
Post edited December 11, 2016 by Rise-T
guys ive been researching the same problem, tried everything, but i am not kidding when i say this. If there is no sound output for the game ( i.e no headphones or speakers connected ) the game crashes after 2 seconds. just plugging headphones caused the game to not crash for me

Post edited April 24, 2017 by Vanquiishher