It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello forum,

I've had some problems with running the game. I'm on Windows 8 by the way, which is basicly the root of all problems.

I've installed the game on my laptop, played it, but the game was fullscreen, in a window. Didn't remember that being there with WIndows 7. So I change some things in the configuration file. As soon as I open the file for the 2nd time, it's empty with no settings to adjust. I know of the ubi.conf file, but that's not as easy to understand.

So I've installed the game on my PC, with Win8, and basicly the same problems occur. Set-up file was re-downloaded so not on my fault. ANyone has any remedies? I am trying to record the gameplay from it, but being windowed and all, hinders my Fraps from working.

edit: I should mention; after playing with the settings on my laptop, the game thought it'd be funny to delete my 85% savefile.
Post edited April 07, 2013 by HKboy
avatar
HKboy: Hello forum,

I've had some problems with running the game. I'm on Windows 8 by the way, which is basicly the root of all problems.

I've installed the game on my laptop, played it, but the game was fullscreen, in a window. Didn't remember that being there with WIndows 7. So I change some things in the configuration file. As soon as I open the file for the 2nd time, it's empty with no settings to adjust. I know of the ubi.conf file, but that's not as easy to understand.

So I've installed the game on my PC, with Win8, and basicly the same problems occur. Set-up file was re-downloaded so not on my fault. ANyone has any remedies? I am trying to record the gameplay from it, but being windowed and all, hinders my Fraps from working.

edit: I should mention; after playing with the settings on my laptop, the game thought it'd be funny to delete my 85% savefile.
Hey. I have the same problem. I just wanted to know if you ever figured anything out. Sorry, wish i knew of a solution myself.
Sounds like the same problem I have on win8 64bit
Has anyone discovered how to solve this?

I'm really frustrated that my game only runs fullscreen with a windowed mode frame arround. Also, I can't capture the game with broadcasters (xsplit or open broadcaster)
Post edited June 24, 2013 by pentaleks
Hi all.

I have this problem too. If it helps i have an Intel Graphics card in my laptop and only Rayman 2 seems to have this issue.

Has anyone got any further with fixing this?
I actually had the same problem with 8, so I installed it on 7 and now it works like a charm, this is surely one of the problems I have with Windows 8.
Rayman 2 / Windows 8 64-Bit / Full Screen Fix

1. Download, nGlide ,search it on Google

2. Install it, Run nGlide and config it

3. (Optional) Perhaps you need to run the graphic Configuration of Rayman 2 to initialize the Glide Driver

4. Run Rayman 2, it should work now

Enjoy!
avatar
Sillage: Rayman 2 / Windows 8 64-Bit / Full Screen Fix

1. Download, nGlide ,search it on Google

2. Install it, Run nGlide and config it

3. (Optional) Perhaps you need to run the graphic Configuration of Rayman 2 to initialize the Glide Driver

4. Run Rayman 2, it should work now

Enjoy!
unfortunately after nglide's installation, there is no option to run rayman using glide
Got it working on my machine (Win 8 64 bit, FX 4170, Radeon HD 7850). Follow the instructions at the PC Gaming Wiki page (won't let me post links, probably because this is my first post) to install and set up nGlide, then set rayman2.exe to run as administrator.

If everything works correctly, your screen will show the 3dfx logo at game startup, then run normally in fullscreen. At least in my case, the screen also flickers for a few seconds after the 3dfx logo before starting up perfectly fine. Let me know if this works for the rest of you, I'll update the PC Gaming Wiki page with this info if it does.
And after roughly 2 years this still works. This fix just made my day!
"unfortunately after nglide's installation, there is no option to run rayman using glide"


GOG version has f* up access to GXSetup which is responsible for settings, and doesn't let through options correctly.
It's because few files is missing comparing to original retail version.
Just use my fix and get GXSetup back (run as admin) to set resolution,
install nGlide, and get also full screen back.
dropbox.com/s/rdv7uieevzt8hmd/Rayman%202%20Windowed%20Mode%20fix.zip?dl=0
For me Glide has better shaders, but colors and cleanliness of textures may be worse in overall
Post edited April 06, 2018 by deton24
avatar
deton24: GOG version has f* up access to GXSetup which is responsible for settings, and doesn't let through options correctly.
It's because few files is missing comparing to original retail version.
Just use my fix and get GXSetup back (run as admin) to set resolution,
install nGlide, and get also full screen back.
dropbox.com/s/rdv7uieevzt8hmd/Rayman%202%20Windowed%20Mode%20fix.zip?dl=0
For me Glide has better shaders, but colors and cleanliness of textures may be worse in overall
this worked for me thanks
If someone does not want to use nGlide, use Dxwrapper (for default DX6 renderer):

Download:
github.com/elishacloud/dxwrapper/releases
Copy dxwrapper.ini, dxwrapper.dll, ddraw.dll (stub directory), into Rayman 2 directory
Edit dxwrapper.ini:
FullScreen = 1

+ The best DX6 wrapper performance for this game. Behaves smoother than dgVoodoo and WineD3D. No 30 FPS dips.
- Overlays cause major FPS drops (e.g. Fraps). It's just enough to hide them by keyboard shortcut if available.
Post edited April 06, 2018 by deton24