It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Ok this should be the last update. Everything is sorted and working fine now.

My goal was to remove all graphics related drivers completely and I did so by uninstalling ATI's drivers and using CCleaner to clean it up as well as removing DirectX 9.0c from my computer using this method:

Next I tried to reinstall DirectX 9.0c using the jun 2010 distributable but I ended up getting an 'internal error'. Since I had an ISO version of WinXP SP3, I used that to repair my windows installation. I opened 'dxdiag' using the 'Run..' command in the Start menu and it said that DirectX 9.0 was installed (thus confirming that windows was repaired.)
I then proceeded to install the Jun 2010 distributable just to make sure it was as up to date as possible.

I then installed the latest ATI Catalyst drivers (the one dated 26/01/11 (or Jan 26, 2011) minus that SDK thing that it came with. Restarted and checked if BFBC2 was working by playing a match. It worked fine.

I then opened Psychonauts to see if it would stall or error. I was able to play for around +-30 mins with no issues whatsoever. I exited and re-entered the game with no issues whatsoever. I did this 2 more times with no issues popping up.


- deleting atkdisp's associated drivers (ASUS OSD, etc) was not a solution

- disabling shadows was not a solution

- graphics drivers (corrupted or improperly installed) were the culprit

If this changes I will repost but for now, everything seems quite gravy.
Post edited January 29, 2011 by wildhind
Glad you got it working!

wildhind: - disabling shadows was not a solution
Does that mean you can run the game with shadows enabled now?