It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just installed Timeshock for the first time after the Windows Version was added and found that I can't choose the highest resolution (1600xsomething), the option is blacked out. Does anyone have an idea what I have to do to be able to choose it?

Thanks and regards!
I also have this problem
Andxgo: I also have this problem
here is a simple fix.
You need to download an updated version of winmm.dll and replace the dll in game's directory.

Browse to this page and download the file

You can now disable any 'Compatibility mode' settings. Leave 'Run as an administrator' enabled.

There seems to be an issue with one track, when Quickshot was enabled. After just a few seconds the track aborts and the main game sound track is played. But this might be a general issue with the windows version.

Have fun ;)