It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi!
I tried to start Big Race USA on my machine but it refuses to start. It just switches my resolution to 640x480 and gradually goes up the resolution ladder (up to 1600x1200 I guess) and then starts back at 640x480. Nothing else happens.
Compatiblity Mode with Windows XP SP3, starting as administrator and forcing 640x480 does nothing at all.

My machine:
Win 10 Pro x64
Intel Core i5 8600k
16GB RAM
GF 1070
avatar
ShiroiRyuLuga: Hi!
I tried to start Big Race USA on my machine but it refuses to start. It just switches my resolution to 640x480 and gradually goes up the resolution ladder (up to 1600x1200 I guess) and then starts back at 640x480. Nothing else happens.
Compatiblity Mode with Windows XP SP3, starting as administrator and forcing 640x480 does nothing at all.

My machine:
Win 10 Pro x64
Intel Core i5 8600k
16GB RAM
GF 1070
same issue here.... changes desktop res repeatedly in a loop, doesnt do anything at all. did you ever resolve this or is it refund time?
my laptop has a weird resolution of 3200*1800 but i'd assume it would be able to run in a lower mode.
Here too. Resolution changes in a loop. No fun, no go. Very strange. GOG, FIX THIS ASAP.

Funny thing is: After this loop it STARTS. Although it's stuck on the main screen. It's running but the buttons are inresponsive.
Post edited December 21, 2018 by Darklord666
update on my experience:
I left mine running and went to make a sandwich, when I came back it was working so it must have eventually fixed something. The menus were fine too.
And the next time I ran it it worked first time so i'm guessing its trying to autodetect screen settings or something, it just takes a very long time. Let it run.
I eventually had the same issue with Timeshock(windows) which I also bought that had *more* problems (I had to fix the winmm.dll first, as it wouldnt run at all.)

however Fantastic Journey had no problems whatsoever. how about that... ;)

So i've got all 3 windows versions working now thankfully, but its been a complete pain in the arse to get them working. I'm leaving this to help others as I havent even got a reply from support yet.
avatar
Darklord666: Funny thing is: After this loop it STARTS. Although it's stuck on the main screen. It's running but the buttons are inresponsive.
Ah I didnt get this issue, cant be any help i'm afraid. :(
Post edited December 22, 2018 by Gamecat666
Now I got it working too. I just started BRU again. The loop was still there but much shorter. After BRU started it worked normally. Great table but the loop is still an issue that should be fixed.
Thanks for sharing your experience. I have the same issue and will try letting it run for more time now.