It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Just installed it. I try to run it, it gives me the cute warning/disclaimer, then the screen turns black. Nothing short of a hard shutdown can bring my machine back from it.
Win Vista 64 bit
4 gb ram
Geforce GT 220 card
Any help would be appreciated!
This question / problem has been solved by snarfbucketimage
Have you tried all the usual compatibility settings, running as admin, reinstalling?
Yup. Reinstalled, ran it in compatibility mode, and I'm always set as admin. Still the big black screen.
Its a bit of a weird step but try disabling your sound card via your hardware device manager, then try to load into the game.
Well isn't that going to kill sound to the game?
snarfbucket: Well isn't that going to kill sound to the game?

It may run through your onboard sound if your motherboard supports it otherwise yes it will. It's mainly for testing purposes, if you disable your sound card and the game loads up then we can be fairly sure its a sound issue and then try to solve that. If not we can look at other options.
Post edited October 23, 2009 by Ralackk
Tried it. No luck.
Figured it out. It's my firewall. I tried running Civ3, same exact problem. Disabled Comodo, everything works fine.
Post edited May 24, 2011 by Funke
now that's good news :)
I would try to find a new firewall though I've never been a fan of Comodo, it always caused more hassle then good. I actually prefere windows firewall over it.