It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello,

I tried running Planescape on my machine and it said that it required libssl.so.1.0.0 as a dependency.
Unfortunately I can't install it because the repos can't find it

please help
avatar
megatron_6: Hello,

I tried running Planescape on my machine and it said that it required libssl.so.1.0.0 as a dependency.
Unfortunately I can't install it because the repos can't find it

please help
https://pkgs.org dl the package for ur distro extract it somewhere and use ld preload
avatar
megatron_6: Hello,

I tried running Planescape on my machine and it said that it required libssl.so.1.0.0 as a dependency.
Unfortunately I can't install it because the repos can't find it

please help
I had the same problem on my laptop running Fedora 29. I couldn't find any package providing openssl1.0.0.
I managed to run the game by building the missing libraries from source.

To build OpenSSL, first the following must be installed in your system (the way to install them is specific to your particular Linux distribution):
* git
* make
* Perl 5
* an ANSI C compiler
* a development environment in form of development libraries and C header files

Clone the source code for the required version and build:
cd ~
git clone --branch OpenSSL_1_0_0-stable --single-branch --depth 1 https://github.com/openssl/openssl.git openssl_1.0.0
cd openssl_1.0.0
./config shared
make

If the build completes successfully, you'll see the required library files:
$ ls lib*so*
libcrypto.so libcrypto.so.1.0.0 libssl.so libssl.so.1.0.0

To run the game with these libraries, change directory to the game's install folder and launch it with this command:
LD_LIBRARY_PATH=~/openssl_1.0.0 ./start.sh
Post edited December 25, 2018 by yicristi
avatar
megatron_6: Hello,

I tried running Planescape on my machine and it said that it required libssl.so.1.0.0 as a dependency.
Unfortunately I can't install it because the repos can't find it

please help
avatar
yicristi: I had the same problem on my laptop running Fedora 29. I couldn't find any package providing openssl1.0.0.
I managed to run the game by building the missing libraries from source.

To build OpenSSL, first the following must be installed in your system (the way to install them is specific to your particular Linux distribution):
* git
* make
* Perl 5
* an ANSI C compiler
* a development environment in form of development libraries and C header files

Clone the source code for the required version and build:
cd ~
git clone --branch OpenSSL_1_0_0-stable --single-branch --depth 1 https://github.com/openssl/openssl.git openssl_1.0.0
cd openssl_1.0.0
./config shared
make

If the build completes successfully, you'll see the required library files:
$ ls lib*so*
libcrypto.so libcrypto.so.1.0.0 libssl.so libssl.so.1.0.0

To run the game with these libraries, change directory to the game's install folder and launch it with this command:
LD_LIBRARY_PATH=~/openssl_1.0.0 ./start.sh
Having trouble running this game and following your ideas i still get :
Torment64: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
avatar
yicristi: I had the same problem on my laptop running Fedora 29. I couldn't find any package providing openssl1.0.0.
I managed to run the game by building the missing libraries from source.

To build OpenSSL, first the following must be installed in your system (the way to install them is specific to your particular Linux distribution):
* git
* make
* Perl 5
* an ANSI C compiler
* a development environment in form of development libraries and C header files

Clone the source code for the required version and build:
cd ~
git clone --branch OpenSSL_1_0_0-stable --single-branch --depth 1 https://github.com/openssl/openssl.git openssl_1.0.0
cd openssl_1.0.0
./config shared
make

If the build completes successfully, you'll see the required library files:
$ ls lib*so*
libcrypto.so libcrypto.so.1.0.0 libssl.so libssl.so.1.0.0

To run the game with these libraries, change directory to the game's install folder and launch it with this command:
LD_LIBRARY_PATH=~/openssl_1.0.0 ./start.sh
avatar
porphiron: Having trouble running this game and following your ideas i still get :
Torment64: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
If you run `LD_LIBRARY_PATH=/path/to/libraries ldd /path/to/Torment64` (or `LD_LIBRARY_PATH=/path/to/libraries /lib64/ld-*.so --list /path/to/Torment64`), it'll list all the dynamic libraries (like DLLs) that are needed to run Torment and where they were found. If the path you gave to LD_LIBRARY_PATH doesn't contain those libs, you'll see the following in the list.

$ ldd /path/to/Torment64
...
libssl.so.1.0.0 => not found
libcrypto.so.1.0.0 => not found
...

So ideally what you'll want to do after building OpenSSL is make sure those libraries are located in the directory that you assigned to LD_LIBRARY_PATH. You should see the files "libcrypto.so.1.0.0" and "libssl.so.1.0.0" wherever you built OpenSSL. Like `file /path/to/openssl/lib.s.1.

$ file /path/to/openssl/libssl.so.1.0.0
libssl.so.1.0.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), statically linked

$ file /path/to/openssl/libcrypto.so.1.0.0
libcrypto.so.1.0.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), statically linked

Now when you list all the libraries using "ldd" iff you get the following error message, then this is saying that your build of OpenSSL didn't include the version information for some reason.

$ ldd /path/to/Torment64
libcrypto.so.1.0.0: no version information available (required by game/Torment64)
libssl.so.1.0.0: no version information available (required by game/Torment64)
...
libssl.so.1.0.0 => /path/to/libssl.so.1.0.0 (0x00007fbaff0f0000)
libcrypto.so.1.0.0 => /path/to/libcrypto.so.1.0.0 (0x00007fbafee9b000)
...

If this happens, then you might need to do another trick to link OpenSSL with version information by using a version-script. To do this, look at the version of Torment using readelf like the following.

$ readelf -V Torment64 | grep OPENSSL | grep Name
0x0050: Name: OPENSSL_1.0.0 Flags: none Version: 11
0x00b0: Name: OPENSSL_1.0.1 Flags: none Version: 10
0x00c0: Name: OPENSSL_1.0.0 Flags: none Version: 5

So, this shows our build of OpenSSL needs to provide these two versions. Create a file in your OpenSSL build directory as follows.

$ cat > openssl.version-script <<EOF
OPENSSL_1.0.0 {
global:
*;
};

OPENSSL_1.0.1 {
global:
*;
};
EOF

Now when you configure, make sure to add the following options to use the version-script. Afterwards, run "make" and wait for it to build.

$ ./config shared -Wl,--version-script=/path/to/openssl.version-script
...
$ time make
...

Now if you run the "ldd" command that we described previously with LD_LIBRARY_PATH pointing to the OpenSSL build directory, it should list all of the shared libraries and their complete paths. At this point, you should be able to run Torment with the LD_LIBRARY_PATH set to OpenSSL's build directory.

$ LD_LIBRARY_PATH=/path/to/openssl/directory ldd /path/to/Torment64
...

(Torment seems to look for its files relative to your current working directory, so make sure to "cd game" and run it as `LD_LIBRARY_PATH=whatever ./Torment64`)
Post edited December 19, 2020 by amoraphobe
avatar
megatron_6: Hello,

I tried running Planescape on my machine and it said that it required libssl.so.1.0.0 as a dependency.
Unfortunately I can't install it because the repos can't find it

please help
avatar
yicristi: I had the same problem on my laptop running Fedora 29. I couldn't find any package providing openssl1.0.0.
I managed to run the game by building the missing libraries from source.

To build OpenSSL, first the following must be installed in your system (the way to install them is specific to your particular Linux distribution):
* git
* make
* Perl 5
* an ANSI C compiler
* a development environment in form of development libraries and C header files

Clone the source code for the required version and build:
cd ~
git clone --branch OpenSSL_1_0_0-stable --single-branch --depth 1 https://github.com/openssl/openssl.git openssl_1.0.0
cd openssl_1.0.0
./config shared
make

If the build completes successfully, you'll see the required library files:
$ ls lib*so*
libcrypto.so libcrypto.so.1.0.0 libssl.so libssl.so.1.0.0

To run the game with these libraries, change directory to the game's install folder and launch it with this command:
LD_LIBRARY_PATH=~/openssl_1.0.0 ./start.sh
Oh also, ftr, as mentioned by https://wiki.openssl.org/index.php/Versioning you can use OpenSSL 1.0.0, OpenSSL 1.0,1, or OpenSSL 1.0.2 as they still retain api compatibility with OPENSSL_1.0.0 (specifically the git tags "OpenSSL_1_0_2X" provide compatibility for all of the api versions, OPENSSL_1.0.0, OPENSSL_1.0.1, and OPENSSL_1.0.2).

So you can still get some of the later fixes/patches from 2019 into your 2016 library. I'm personally using openssl-1.0.2u for planescape.
Post edited December 19, 2020 by amoraphobe
As already said one may get problems with the libraries.

The Linux version delivered runs under Ubuntu 18.04 LTS `Bionic' (=Mint 19.x Tricia )
(currently still the most recent release getting support by GOG),
but with current HW one may need recent distros, too.

So for GNU/Linux versions like the current Canonical supported versions like:
Ubuntu 20.04 LTS `Focal' (=Mint 20.x Ulyana) or Ubuntu 20.10 STS `Groovy',
one is in need of current libs.
I used those of Ubuntu Eoan (19.10 STS - EoL but more compatible) ...
and then it works fine for my systems.

Unfortunately a 1.2 MB tgz incl. adapted start.sh and two libs can not be added (as image).
So concerning the start.sh script I added at the end of the "# Initialization" passage:
~~~
# JMB -v
TESTSTRVER=`cat /etc/*elease* | grep VERSION_ID | cut -d\" -f2`
if [[ "${TESTSTRVER}" == "20.10" ]] || [[ "${TESTSTRVER}" == "20.04" ]] || [[ "${TESTSTRVER}" == "19.10" ]]; then
  echo "* Current Ubuntu distro detected ... need for additional libraries:"
   echo "\-> Old library path: >>$LD_LIBRARY_PATH<<."
  export LD_LIBRARY_PATH=./lib64:$LD_LIBRARY_PATH
   echo "\-> New library path: >>$LD_LIBRARY_PATH<<!"
else
  echo "* Older Ubuntu distro used ... no need for additional libraries"
  echo "* ... or versionstring >>${TESTSTRVER}$<< not interpreted correctly."
fi
# JMB -^
~~~
and added to the install path the directory "game/lib64" containing:
-rw-r--r-- 1 jmb jmb 2357760 Feb 26 2019 libcrypto.so.1.0.0
-rw-r--r-- 1 jmb jmb  426232 Feb 26 2019 libssl.so.1.0.0

I will try to reach GOG support (and maybe later Beamdog support) so maybe this get fixed ...
but my expectations are not that high.
But maybe this explanation can help someone ...

Happy New Year!

JMB
Post edited January 01, 2021 by JMB9
gawd what crazy misguided stuff ppl are up to... and then they say Linux is nawt working fer them. jeez...

for the record
TL;DR get the older openssl from pkgs.org, unpack (dpkg -x package.deb .), launch the game LD_LIBRARY_PATH=path_to_libs ./Torment64

3 easy steps.