It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I recently got into BG:EE. It's amazing how good the zoom function it, really bringing the game to life in a way that wasn't available before.

For some reason, PS:T EE's zoom doesn't have filtering when you zoom in for anything but the characters. Why is this? As soon as you zoom in just a bit, the surroundings look blocky, warped and ugly. Please tell me this is a bug... I want to enjoy PS:T's beautiful scenery just the same way I enjoy BG's. PS:T actually has far more beautiful art, and it's a shame I can't enjoy it zoomed in even the least bit.
Try different graphics settings, - it may depend on your PC specs. For example, Compability Renderer.

Here how it looks on my PC: by default - s3.amazonaws.com/uploads.hipchat.com/30965%2F4320681%2FeUYqfUQXgiiq6oK%2FPSTEE-2017-mar-30-001.jpg

Using Compability Renderer - s3.amazonaws.com/uploads.hipchat.com/30965%2F4320681%2FzxFWZZC7nPBZi4j%2FPSTEE-2017-mar-30-002.jpg
Go under Options > Graphics, and select Compatibility Renderer. You MUST restart the game for this change to take effect.

This will run the game under a DirectX graphics engine (instead of OpenGL) which uses a much better anti-aliasing filter. Supposedly this mode is intended for running on non-gaming PCs using an integrated graphics chipset (Intel Graphics Media Accelerator, etc.) However, even on my very high-end desktop gaming system I prefer running in this mode. I've yet to find any downside to it and the scaling/anti-aliasing looks noticeably better.

This applies to Baldur's Gate 1 & 2 and Icewind Dale as well.

EDIT: **points above.** Yeah -- do what the Beamdog dude said. :-) Julius, is there any reason why you wouldn't want to always run in the Compatibility mode? I haven't noticed any downside to it.
Post edited April 21, 2017 by Ryan333
Thanks for the replies.

This obviously won't work for my Mac laptop, but I'll try it at home on my PC.

Why would this not be available on the OpenGL renderer though? In BG:EE, I get zoom filtering in OpenGL as well. How come?

I'd like to understand the thinking behind this. Is it really hard to implement this feature?
Try to create a feature request on support.baldursgate.com and contact our support at support@beamdog.com.
Done.

I've also confirmed that in every other EE game (BG, BG2, IWD), the OpenGL renderer does filtering. So this seems like something that was accidentally left out in PST.

Also, the difference between PST's bad OpenGL renderer and its compatibility renderer is massive. With compatibility, I can play zoomed in and enjoy the beautiful, rich artwork. In the PST OpenGL renderer, even a bit of zoom is intolerable.
avatar
Bluddy: Done.

I've also confirmed that in every other EE game (BG, BG2, IWD), the OpenGL renderer does filtering. So this seems like something that was accidentally left out in PST.

Also, the difference between PST's bad OpenGL renderer and its compatibility renderer is massive. With compatibility, I can play zoomed in and enjoy the beautiful, rich artwork. In the PST OpenGL renderer, even a bit of zoom is intolerable.
Don't know if this will help, but I noticed under the Alternate Renderer (D3d) in BG2 that if you selected the graphics option to scale the interface up--the entire game(!) is scaled down to a lower resolution, instead (which scales up the interface.) I noticed that the game itself then appears really blocky when using the mouse, since no other gaming scaling can now occur. This is running d3d under a 2560x1440 res. If you deselect "scale the Interface" *then* normal scaling filtering occurs with the mouse zoom. Will check OpenGL and come back.--OK, same behavior in OpenGL. Zoom filtering is much better in BG2 with "scaling the interface" turned off in both D3d and OpenGL.

Win10x64 16179, RX-480 8GB, Crimson 17.4.3 drivers.

EDIT: Note also that I have Sprite Outlines turned off.
Post edited April 25, 2017 by waltc
avatar
waltc: Don't know if this will help, but I noticed under the Alternate Renderer (D3d) in BG2 that if you selected the graphics option to scale the interface up--the entire game(!) is scaled down to a lower resolution, instead (which scales up the interface.) I noticed that the game itself then appears really blocky when using the mouse, since no other gaming scaling can now occur. This is running d3d under a 2560x1440 res. If you deselect "scale the Interface" *then* normal scaling filtering occurs with the mouse zoom. Will check OpenGL and come back.--OK, same behavior in OpenGL. Zoom filtering is much better in BG2 with "scaling the interface" turned off in both D3d and OpenGL.

Win10x64 16179, RX-480 8GB, Crimson 17.4.3 drivers.

EDIT: Note also that I have Sprite Outlines turned off.
It doesn't seem like this option was kept for PST. I'm guessing they changed a bunch of the code and broke the filtering feature in OpenGL. Everybody play-testing assumed this was the way the game was supposed to look (blocky and ugly with zoom) since it's 'old', when in fact the OpenGL engine is perfectly capable of zooming in with filtering. Why did Beamdog's QA not pick up on this though? No idea.
avatar
Ryan333: Go under Options > Graphics, and select Compatibility Renderer. You MUST restart the game for this change to take effect.
This will run the game under a DirectX graphics engine (instead of OpenGL) which uses a much better anti-aliasing filter. , is there any reason why you wouldn't want to always run in the Compatibility mode? I haven't noticed any downside to it.
Thanks, this post should be sticked, or the game patched...
avatar
Ryan333: Go under Options > Graphics, and select Compatibility Renderer. You MUST restart the game for this change to take effect.
This will run the game under a DirectX graphics engine (instead of OpenGL) which uses a much better anti-aliasing filter. , is there any reason why you wouldn't want to always run in the Compatibility mode? I haven't noticed any downside to it.
avatar
ERISS: Thanks, this post should be sticked, or the game patched...
Seconded. Until I read some of these posts I didn't even suspect that using the "compatibility renderer" would offer such a massive improvement. I was just going to accept that zooming in would look like crap.

Changing this setting has made the game so much better. It's also gotten me into the stupid habit of changing zoom levels constantly for some reason, but maybe I have ADD or something... ;)
> Changing this setting has made the game so much better. It's also gotten me into the stupid habit of changing zoom levels constantly for some reason, but maybe I have ADD or something... ;)

Changing zoom levels is a *huge* convenience feature. It's single-handedly made Baldur's Gate 1 enjoyable for me. By focusing on the relevant action and yet being able to get a bird's eye view when needed, it improves infinity games far more than I would have suspected.

BTW, Beamdog have acknowledged that this is a bug. See http://support.baldursgate.com/issues/30519
avatar
Bluddy: BTW, Beamdog have acknowledged that this is a bug. See http://support.baldursgate.com/issues/30519
Is there perhaps an ETA for a patch?
FYI, this has been resolved in the latest patch. Thanks, Beamdog!