It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

All the other maps have loaded flawlessly so far. This one however, causes the loading bar to fill up quickly and then the game just hangs at that point. Help is greatly appreciated.
EDIT: It was just a matter of waiting a bit longer than usual, thanks a bunch.
Post edited April 06, 2009 by Mister.White
This question / problem has been solved by Ralackkimage
Strange, zombiguy35 have problem with the same level here:
I think You should first off all upgrade Your video card's drivers. Then try to wait minute or two during loading - this is boss level, so maybe giant model is the reason. Finally, if nothing will help, try to download the game again.
Post edited April 05, 2009 by Nox_A15
Unfortunately, updating my drivers didn't work, and I had waited a few minutes during the "loading." Also, while the OP in the other topic can actually load the level, I can't.
Thanks anyway.
Post edited April 05, 2009 by Mister.White
Please try to download the game again. I am not able to tell if this will work, though.
Post edited April 05, 2009 by Nox_A15
Try turning all graphics options on lowest possible settings and disable bloom etc, try to load the level again and give it a good 3-4 minutes if it doesn't load before.
If that doesn't work could you post your computer specs and OS so we can better examine and try to fix the problem?
Post edited April 06, 2009 by Ralackk
I experienced a much longer loading time on this level as well. Strange that it seems completely unlinked to the progress bar, which fills up in about five seconds.
[EDIT] I just tried this again. The necrogiant killed me, and I clicked to reload the last checkpoint. This time, the progress bar filled up almost instantly, and it wrote "Game loaded" in the top left corner of the screen. Then nothing more happened. After 5 minutes of looking at the loading screen, I tried alt-tabbing out, but found that I couldn't. I did a ctrl-alt-delete and pulled up the task manager. That got me out to the desktop, and a window stating that painkiller.exe had stopped working.
Post edited April 18, 2009 by Wishbone
Also had the same problem with this level. It seemed to load in seconds, but then i had to wait 3-4 minutes for it to open.
However, then i had NO necrogiant. For a few minutes i ran around the empty level with the ominous music thinking "what a great way to build tension!!" and expecting something to appear or jump out at me. After about 5 minutes of that i realised it wasn't intended :-(