It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello fellow Linux gamers!

Here you’ll find scripts allowing you to build packages for Debian, Arch Linux and any derivative (Ubuntu, Manjaro, Linux Mint, etc.) from your GOG installers for Ori and the Blind Forest.
You will then be able to easily install these packages with you favourite packages manager.

Download links and usage instructions can be found on the following page:
Ori and the Blind Forest

We hope you’ll enjoy the ease-of-use provided by these scripts as much as we enjoy writing and tweaking them ;)

Here you go for more supported games!

-----

Salut camarades Linuxiens !

Vous trouverez ici des scripts vous permettant de construire des paquets pour Debian, Arch Linux ou n’importe quelle distribution dérivée de celles-ci (Ubuntu, Manjaro, Linux Mint, etc.) à partir de vos installeurs GOG pour Ori and the Blind Forest.
Ces paquets pourront ensuite être installés facilement via votre gestionnaire de paquets habituel.

Les liens de télechargement et les instructions d’utilisation se trouvent sur la page suivante :
Ori and the Blind Forest

Nous espérons que vous apprécierez le confort apporté par ces scripts autant que nous apprécions les écrire et les améliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited July 14, 2018 by vv221
Bonjour. Merci beaucoup pour vos efforts, mais malheureusement je n'ai pas arriver de le faire fonctionner.

D'abord j'ai du faire la commande `umask 002`, sinon le fakeroot ne peut pas faire le progiciel. Ça m'a pris un peu de temps, mais après j'ai un autre problem, peut-être lié a ma carte 3D.

Lorsque je lance le jeu tout commence bien: j'ai la petite personnage en courant sur l'écran, mais ça commence a ralentir après environs six seconds. J'ai l'impression que quelque chose cloche au niveau de FPS.. Donc j'ai fait pas mal de recherche, mais je ne trouve rien jusqu'ici.

Ma carte vidieo est un Haswell Mobile (UTL). Selon wine il est bien reconnu pendent le lancement.

Si vous avez une idée je vous remercierais.
Post edited July 14, 2018 by Mark_Jaroski
avatar
Mark_Jaroski: (…)
Essaye de lancer le jeu depuis une console en forçant l’utilisation de DirectX 9 :
ori-and-the-blind-forest -force-d3d9
Est-ce que ça améliore les performances dans ton cas ?
avatar
Mark_Jaroski: (…)
avatar
vv221: Essaye de lancer le jeu depuis une console en forçant l’utilisation de DirectX 9 :

ori-and-the-blind-forest -force-d3d9
avatar
vv221: Est-ce que ça améliore les performances dans ton cas ?
C'est un peu mieux. J'ai reçu un error, donc je peux commencer le débrouiller. Merci encore !
avatar
Mark_Jaroski: (…)
Tiens-moi au courant de tes résultats, on pourra les utiliser pour améliorer le script d’installation.
Je vais commencer par ajouter le mode DirectX 9 par défaut, pour qu’il n’y ait plus besoin de donner explicitement cette option.
avatar
Mark_Jaroski: (…)
avatar
vv221: Tiens-moi au courant de tes résultats, on pourra les utiliser pour améliorer le script d’installation.
Je vais commencer par ajouter le mode DirectX 9 par défaut, pour qu’il n’y ait plus besoin de donner explicitement cette option.
Merci encore !

Quelque chose qui se démarque lorsque j'active le débogage est cette ligne:

wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
000b:err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)


Mais le fichier existe :

$ ls ori-and-the-blind-forest/drive_c/windows/system32/winemenubuilder.exe
ori-and-the-blind-forest/drive_c/windows/system32/winemenubuilder.exe*
avatar
Mark_Jaroski: wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
000b:err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
Tu peux ignorer cet avertissement, c’est le résultat d’une bidouille appliquée par ./play.it pour empêcher WINE de créer des entrées de menu.

Pour info on a pu tester ce jeu sur un GPU dédié AMD avec le pilote libre amdgpu et un GPU dédié nVIDIA avec le pilote non-libre nvidia, et dans les deux cas il n’y a aucun souci de performances.
Je n’aurai par contre pas accès à une machine utilisant une puce graphique intégrée Intel suffisamment puissante pour tester ce jeu avant plusieurs semaines.
avatar
Mark_Jaroski: wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
000b:err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
avatar
vv221: Tu peux ignorer cet avertissement, c’est le résultat d’une bidouille appliquée par ./play.it pour empêcher WINE de créer des entrées de menu.

Pour info on a pu tester ce jeu sur un GPU dédié AMD avec le pilote libre amdgpu et un GPU dédié nVIDIA avec le pilote non-libre nvidia, et dans les deux cas il n’y a aucun souci de performances.
Je n’aurai par contre pas accès à une machine utilisant une puce graphique intégrée Intel suffisamment puissante pour tester ce jeu avant plusieurs semaines.
D'accord. Je commence à penser que ma problème est du à RAM. Je n'ai que 8Go et en combinaison avec la carte Intel ce jeu est trop gourmand.

Merci quand meme !
avatar
Mark_Jaroski: (…)
Je pencherais plutôt pour la carte graphique que la RAM, ici le jeu consomme beaucoup moins que les 8Go qu’il a à disposition.
Update

Force Direct3D 9 mode, should improve compatibility with some setups.