It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have the GOG version of “Nexus – The Jupiter Incident” and have installed it on three systems:

1. Tower with Windows 10, AMD FX-8320 and AMD R9 380
2. Laptop with Windows 10, Intel Core i7-3xxx and NVIDIA GeForce 670M
3. Laptop with Windows 7, Intel Core i5-3xxx

All Windows versions are the Professional 64-Bit version.

The multiplayer runs well on system 1 and 3, it crashes on system 2. I can launch the game and it goes into a full screen menu. I can play the the single player campaign just fine, so it probably is a network related issue. When I click on multiplayer and try to start a server or connect to another server, the game freezes for 12 seconds and then Windows tells me that it has crashed. This is completely reproducible.

I have tried a bunch of things but I ran out of ideas:

- People reported that an installation path with spaces can cause errors, so I have changed that. This did not change anything and does not seem to be a problem on the other computers.

- Disable the chat in the multiplayer
- Restart the computer a bunch of times
- Re-install the game into a different location
- Re-install the NVIDIA GeForce driver
- Disable audio completely within the game
- Use the NVIDIA system settings for force the game to use the NVIDIA GPU. The laptop has Optimus which might be problematic. Also I tried to force it to use the Intel GPU.
- Disable Windows 10 “Game Mode”
- Disable Windows firewall
- Tried Windows XP compatibility mode

What else could it be that I have not tried?
martin-ueding: What else could it be that I have not tried?
Enable DirectPlay in Windows on the problem laptop?
Click on the Windows Button and search for "Windows Features" - Click on Activate or deactivate Windows Features.

There should be a folder named "Legacy components". Expand it and enable Direct Play.
Post edited August 29, 2017 by Gydion
This was the culprit, now it seems to work! Thank you very much!