It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone,

I have a weird NPC graphic problem with NWN Diamond Edition (NWN1, not EE) as you can see in the 2 screenshots I attached. Everything else works perfectly, places, Magic, weapons. I didn't even notice it at first since I don't usually zoom in.

I am using Linux Mint 18.3 alongside Win7. NWN is installed on win7 partition.
I am playing it on Linux with WINE by simply double clicking nwmain.exe.
This graphical error only happens when I play the game on Linux. It works normally in Win7 (even the saves I made on Linux).

I didn't say Linux in the question because I saw an other Windows user having the same problem but the question was not resolved.

I also tried to install NWN directly on Linux via both WINE itself or PlayonLinux, the problem was still there.
I also tried to install native Linux version of NWN and also tried script on dotslashplay. Native Linux didn't work at all. The dotslashplay build started as half screen while the rest kept flashing weirdly and for some reason it blocked all keyboard commands like ALT-TAB or kill commands. I had to CTRL+ALT+BACKSPACE to kill everything and restart cinnamon.

It is not really a problem for me, I am merely asking to find the cause behind it and maybe help others in the future. My sexy Sorcerer is already level 9 and about the finish chapter 1.

NOT: The installed version is GOG installer 2.0. I downloaded and installed 2.1 but it didn't change anything.
ss1.jpg (317 Kb)
ss2.jpg (439 Kb)
This question / problem has been solved by jjglvzimage
I don't know anything about Linux, but disabling "Environment Mapping on Creatures" may fix glitchy character skins.
Post edited September 16, 2019 by jjglvz
jjglvz: I don't know anything about Linux, but disabling "Environment Mapping on Creatures" may fix glitchy character skins.
Thanks a lot. I thought I had tested every alternative there but looks like I missed that one. It solved the problem thank you :)

Also, on Linux I am using the Open-Source (nouveau) drivers for my GPU. The problem was also fixed when I changed to the official Nvidia drivers. However, I don't like that one since it creates problems with other software. I am really glad your suggestion worked :)