It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey there,

last week I finished the OC and I decided to take a break and play something else. Today I try starting up another campaign and I get this weird crash that happens all the time. It crashes instantly as soon as it hits the loading screen with "Unpacking module" message. Same thing happens on every campaign I try, even on my old saved files.

What I tried so far is reinstalling the whole game, deleting Neverwinter Nights 2 folder in My documents, reinstalling DX9 and VC++ runtimes, tinkering with various settings in game and in Nvidia panel in case it's something related to graphics. NWN2 client extensions doesn't help either. I even tried moving the temp folder in case it was a problem with lack of space on my C drive.

Only thing that changed between now and then is that I installed 2 other games. No new drivers since then, no new Windows updates (unless you count new definitions for Security Essentials).

Here's the crash log in case someone here can read them: pastebin.com/cDVLVMSW

My specs:
Windows 7
Intel Core i5 4670 @ 3.40Ghz
8GB RAM
NVIDIA GeForce GTX 770 4GB

Any help is appreciated.

EDIT: Okay, it's fixed now. I removed the override folder in the root directory of the game and then moved all my mods into My Documents/Neverwinter Nights 2/override and then it worked.
Post edited December 30, 2017 by pretty_ugly
avatar
pretty_ugly: Hey there,

last week I finished the OC and I decided to take a break and play something else. Today I try starting up another campaign and I get this weird crash that happens all the time. It crashes instantly as soon as it hits the loading screen with "Unpacking module" message. Same thing happens on every campaign I try, even on my old saved files.

What I tried so far is reinstalling the whole game, deleting Neverwinter Nights 2 folder in My documents, reinstalling DX9 and VC++ runtimes, tinkering with various settings in game and in Nvidia panel in case it's something related to graphics. NWN2 client extensions doesn't help either. I even tried moving the temp folder in case it was a problem with lack of space on my C drive.

Only thing that changed between now and then is that I installed 2 other games. No new drivers since then, no new Windows updates (unless you count new definitions for Security Essentials).

Here's the crash log in case someone here can read them: https://pastebin.com/cDVLVMSW

My specs:
Windows 7
Intel Core i5 4670 @ 3.40Ghz
8GB RAM
NVIDIA GeForce GTX 770 4GB

Any help is appreciated.
Whut....
access violation?
G:\Installed Games\NWN2 Complete\nwn2main.exe caused an Access Violation exception in module nwn2main.exe at 0023:008b2d82.

hmmm..... two things I can think off.
Either your Antivirus or this stupid Win7 feature....how is called again, keep forgetting the name: DAU? AUC? it is supposed to protect the user from unwanted access.....

EDIT: In case you are wondering why you weren't able to paste a link, you need a rep of 5 to post links.
One post per day will get you one rep per day (not more ;) )
(and just in case I replaced your 'link' with the real link in my quote of yours ;) )
Post edited December 29, 2017 by Goodaltgamer
I guess you mean UAC? That's disabled. I also tried running the game with antivirus turned off and it didn't help.
avatar
pretty_ugly: I guess you mean UAC? That's disabled. I also tried running the game with antivirus turned off and it didn't help.
Yes, that was the one, as I said, I never can remember the name :D

But:

https://forums.geforce.com/default/topic/473136/pc-games/neverwinter-nights-2-freeze-and-crash-neverwinter-nights-2-storm-of-zehir-gt240-issue/

It might be a Geforce problem.....as above mentioned.

Solution according to this thread is

Neverwinter Nights 2 (actually Storm of Zehir). There is only measure can prevent crash

~

DebugMode 1

Sky 0

(unfortunate not a lot of info in there.....)

Or.....
maybe....

https://neverwintervault.org/project/nwn2/other/nwn2-client-extension

As suggested there, check the registry

and/or use this client extension.

It seems to be only a problem with Geforce drivers. Another thing you could try, using an older version to see if this fixes it.

>>> First of all, AND, try renaming the nwn2main.exe into like never2.exe and try again<<<

If this works, I might know what it is...
avatar
pretty_ugly: I guess you mean UAC? That's disabled. I also tried running the game with antivirus turned off and it didn't help.
avatar
Goodaltgamer: Yes, that was the one, as I said, I never can remember the name :D

But:

https://forums.geforce.com/default/topic/473136/pc-games/neverwinter-nights-2-freeze-and-crash-neverwinter-nights-2-storm-of-zehir-gt240-issue/

It might be a Geforce problem.....as above mentioned.

Solution according to this thread is

Neverwinter Nights 2 (actually Storm of Zehir). There is only measure can prevent crash

~

DebugMode 1

Sky 0

(unfortunate not a lot of info in there.....)

Or.....
maybe....

https://neverwintervault.org/project/nwn2/other/nwn2-client-extension

As suggested there, check the registry

and/or use this client extension.

It seems to be only a problem with Geforce drivers. Another thing you could try, using an older version to see if this fixes it.

>>> First of all, AND, try renaming the nwn2main.exe into like never2.exe and try again<<<

If this works, I might know what it is...
Well, the GeForce drivers I have shouldn't be the problem, since I played the game a week ago with no issues.
I can't even load into the game now so DebugMode is a no go.

I already tried Client Extension. It loads up fine (no error when launching the game) but crashes with the exact same message. It seems to me more like a problem with unpacking the modules but not really sure why it happens.

Renaming the nwn2main.exe doesn't do anything. It still crashes and only difference is this line in the log "never2.exe caused an Access Violation exception in module never2.exe". Thanks for the help though.
avatar
pretty_ugly: Well, the GeForce drivers I have shouldn't be the problem, since I played the game a week ago with no issues.
I can't even load into the game now so DebugMode is a no go.

I already tried Client Extension. It loads up fine (no error when launching the game) but crashes with the exact same message. It seems to me more like a problem with unpacking the modules but not really sure why it happens.

Renaming the nwn2main.exe doesn't do anything. It still crashes and only difference is this line in the log "never2.exe caused an Access Violation exception in module never2.exe". Thanks for the help though.
Soooorry.....

Out of ideas for the moment....

And unpacking the modules....having a damaged file in the GOG-installer (and just only you ;) ).....hmmm.... don't think so... ;)

Game path looks okay....UAC disabled, so even running as admin shall not make a difference....AV turned off....(only as a thought....I know unlikely, but did your AV maybe interfere when you installed it and hence might have damaged the module? ) .....

Oh...sorry about the console, you mentioned it crashed right after loading, so no way to do it.....

Actually while reading up a bit again on it......

[url=https://msdn.microsoft.com/en-us/library/system.accessviolationexception(v=vs.110).aspx]https://msdn.microsoft.com/en-us/library/system.accessviolationexception(v=vs.110).aspx[/url]

Which .NET Frameworks have you got installed?
avatar
pretty_ugly: Well, the GeForce drivers I have shouldn't be the problem, since I played the game a week ago with no issues.
I can't even load into the game now so DebugMode is a no go.

I already tried Client Extension. It loads up fine (no error when launching the game) but crashes with the exact same message. It seems to me more like a problem with unpacking the modules but not really sure why it happens.

Renaming the nwn2main.exe doesn't do anything. It still crashes and only difference is this line in the log "never2.exe caused an Access Violation exception in module never2.exe". Thanks for the help though.
avatar
Goodaltgamer: Soooorry.....

Out of ideas for the moment....

And unpacking the modules....having a damaged file in the GOG-installer (and just only you ;) ).....hmmm.... don't think so... ;)

Game path looks okay....UAC disabled, so even running as admin shall not make a difference....AV turned off....(only as a thought....I know unlikely, but did your AV maybe interfere when you installed it and hence might have damaged the module? ) .....

Oh...sorry about the console, you mentioned it crashed right after loading, so no way to do it.....

Actually while reading up a bit again on it......

[url=https://msdn.microsoft.com/en-us/library/system.accessviolationexception(v=vs.110).aspx]https://msdn.microsoft.com/en-us/library/system.accessviolationexception(v=vs.110).aspx[/url]

Which .NET Frameworks have you got installed?
Hey thanks for all the help. I managed to fix it myself in the end.

Turns out the solution was really simple. I removed the override folder in the root directory of the game and then moved all my mods into My Documents/Neverwinter Nights 2/override and then it worked. Not really sure what was the issue because it worked fine before? Maybe something to do with hard drive going bad and thus moving that folder somewhere else fixed it?

Well, all that matters is that it works now and loads up fine. Thanks again.
avatar
Goodaltgamer: Soooorry.....

Out of ideas for the moment....

And unpacking the modules....having a damaged file in the GOG-installer (and just only you ;) ).....hmmm.... don't think so... ;)

Game path looks okay....UAC disabled, so even running as admin shall not make a difference....AV turned off....(only as a thought....I know unlikely, but did your AV maybe interfere when you installed it and hence might have damaged the module? ) .....

Oh...sorry about the console, you mentioned it crashed right after loading, so no way to do it.....

Actually while reading up a bit again on it......

[url=https://msdn.microsoft.com/en-us/library/system.accessviolationexception(v=vs.110).aspx]https://msdn.microsoft.com/en-us/library/system.accessviolationexception(v=vs.110).aspx[/url]

Which .NET Frameworks have you got installed?
avatar
pretty_ugly: Hey thanks for all the help. I managed to fix it myself in the end.

Turns out the solution was really simple. I removed the override folder in the root directory of the game and then moved all my mods into My Documents/Neverwinter Nights 2/override and then it worked. Not really sure what was the issue because it worked fine before? Maybe something to do with hard drive going bad and thus moving that folder somewhere else fixed it?

Well, all that matters is that it works now and loads up fine. Thanks again.
Sorry for the very late reply. But I also had run into a similar problem recently, and did as you suggested, and it worked. I can now play NWN2.