It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Tried to play co-op yesterday with one other player. Fired up the HOTU expansion, everything went well. When the first combats started, I got insane lag which I couldn't tell was it graphical or network related. I have no idea.

I can play on persistent worlds and get occasional stuttering, but co-op seems totally unplayable.

I used Windows xp SP 2 compatibility mode, and disabled desktop composition on a recent PW test, but the occasional stutter still remains.

Anyone with a similar rig had the same problems?

My specs:

Intel i5-4670k 3.4ghz
8gb memory
Geforce GTX 780
1000mb/s internet connection
Windows 7 Home premium
It is probably because of the other person who hosted the game.
avatar
gutteri: Tried to play co-op yesterday with one other player. Fired up the HOTU expansion, everything went well. When the first combats started, I got insane lag which I couldn't tell was it graphical or network related. I have no idea.

I can play on persistent worlds and get occasional stuttering, but co-op seems totally unplayable.

I used Windows xp SP 2 compatibility mode, and disabled desktop composition on a recent PW test, but the occasional stutter still remains.

Anyone with a similar rig had the same problems?

My specs:

Intel i5-4670k 3.4ghz
8gb memory
Geforce GTX 780
1000mb/s internet connection
Windows 7 Home premium
Sorry, I know it is necromancy but still.. maybe it would help.

Tried to play Co-Op with my girlfriend on LAN, not over net, but LAN and the lag was ... lets say interesting.
What helped me was downloading something called Client Extension.

I admit I have no idea what all it did, but it did help with the LAN lag for sure.