It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So I've been happily playing NWN2 without any issues at all, only a single crash during the entire thing. I then finished it and started play Mask of The Betrayer and now my savegames are constantly being corrupted - Every time I try to load one the game crashes. I then try to load a previous save and it's also crashing. Then a previous save again, however now I'm forced to redo the next 10 mins only to get a corrupt savegame yet again.

It makes no sense. It happens randomly throughout the game. I have no antivirus or anything 'scanning' in the background. All drivers updated. Windows updated.

Specs
FX-8320
R9 270X
8GB DDR3
Windows 7 64bit

Game installed on HDD, saves are on SSD.
Post edited March 25, 2015 by bouncedk
This question / problem has been solved by Hickoryimage
avatar
bouncedk: Game installed on HDD, saves are on SSD.
Is that where your Windows' documents library is located, because NWN2 does it's housekeeping in there ("Neverwinter Nights 2" folder), including saves.
avatar
bouncedk: Game installed on HDD, saves are on SSD.
avatar
Hickory: Is that where your Windows' documents library is located, because NWN2 does it's housekeeping in there ("Neverwinter Nights 2" folder), including saves.
Yes.
avatar
Hickory: Is that where your Windows' documents library is located, because NWN2 does it's housekeeping in there ("Neverwinter Nights 2" folder), including saves.
avatar
bouncedk: Yes.
Then if you are getting random corruptions, have you checked the integrity of the disk?
avatar
bouncedk: Yes.
avatar
Hickory: Then if you are getting random corruptions, have you checked the integrity of the disk?
Yep it's fine as well. Zero errors. It still doesn't make any sense to me whatsoever. Only the expansion is what I'm having issues with.


SSD report
SMART READ DATA
Revision: 10
Attributes List
1: (SSD Raw Read Error Rate) Normalized Rate: 100 Sectors Read: 3151009 Read Errors: 0
5: (SSD Retired Block Count) Spare blocks remaining 100% Retired Block 0
9: (SSD Power-On Hours) Value 89 Total 10065 hrs 35 mins
12: (SSD Power Cycle Count) Power Cycle Life Remaining 98% Number of power cycles 2341
171: (SSD Program Fail Count) Program Error Count 0
172: (SSD Erase Fail Count) Erase Error Count 0
174: (SSD Unexpected power loss count) Unexpected power loss Count 71
177: (Wear Range Delta) Wear Range Delta 7%
181: (Program Fail Count) Program Error Count 0
182: (Erase Fail Count) Erase Error Count 0
187: (SSD Reported Uncorrectable Errors) Normalized Value 100 lifetime URAISE Errors 0
189: (Unrecognized Attribute) Value: 23 Raw Data: 17 00 4d 00 11 00 00
194: (SSD Temperature Monitoring) Normalized temp 23 Current 23 High 77 Low 17
195: (SSD ECC On-the-fly Count) Normalized Value 120 Sectors Read 3151009 UECC Count 0
196: (SSD Reallocation Event Count) Normalized Value 100 Reallocation Event Count 0
201: (SSD Uncorrectable Soft Read Error Rate)Normalized Value 120 Sectors Read 3151009 Uncorrectable Soft Error Count 0
204: (SSD Soft ECC Correction Rate (RAISE) Normalized Value 120 Sectors Read 3151009 Soft ECC Correction Count 0
230: (SSD Life Curve Status) Normalized Value 100
231: (SSD Life Left) Life Remaining 96%
233: (SSD Internal Reserved) 12147
234: (SSD Internal Reserved) 4087
241: (SSD Lifetime writes from host) lifetime writes 4087
242: (SSD Lifetime reads from host) lifetime reads 4753
Post edited March 25, 2015 by bouncedk
avatar
bouncedk: It still doesn't make any sense to me whatsoever. Only the expansion is what I'm having issues with.
Are you making clean saves, or saving over previous saves? I'm grasping at straws here, because it doesn't make much sense to me, either.
avatar
bouncedk: It still doesn't make any sense to me whatsoever. Only the expansion is what I'm having issues with.
avatar
Hickory: Are you making clean saves, or saving over previous saves? I'm grasping at straws here, because it doesn't make much sense to me, either.
Just overwriting them as they tend to grow quite large - I keep 4 + an autosave (which also corrupts itself from time to time).
avatar
Hickory: Are you making clean saves, or saving over previous saves? I'm grasping at straws here, because it doesn't make much sense to me, either.
avatar
bouncedk: Just overwriting them as they tend to grow quite large - I keep 4 + an autosave (which also corrupts itself from time to time).
Don't overwrite, because anything that's corrupt, even a graphic file, that doesn't get replaced during save will carry over. Make clean saves always, even if it means deleting the previous save/s.
avatar
bouncedk: Just overwriting them as they tend to grow quite large - I keep 4 + an autosave (which also corrupts itself from time to time).
avatar
Hickory: Don't overwrite, because anything that's corrupt, even a graphic file, that doesn't get replaced during save will carry over. Make clean saves always, even if it means deleting the previous save/s.
Still doesn't explain why it's only the expansion doing this. Same engine, same game, just a different module.
But thanks for the help, I'll Google some more =)
avatar
Hickory: Don't overwrite, because anything that's corrupt, even a graphic file, that doesn't get replaced during save will carry over. Make clean saves always, even if it means deleting the previous save/s.
avatar
bouncedk: Still doesn't explain why it's only the expansion doing this. Same engine, same game, just a different module.
All it takes is one corrupt file inside the save folder that carries over. If it's related to the expansion, that's a coincidence.
Ok tried a new game, saved in 4 different slots (never overwriting) and it's still doing it. Think this game is broken or I need to reinstall it.

Dangit, spent 10h in the expansion already.