It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So I have no idea how I managed to get things screwed up this badly but apparently I did. I just got NWN2 and when I try to start the campaign the loading screen freezes at "Logging the character into the module". I've been looking all over for a fix but can't find anything so if anyone has ideas I'd be so grateful. I've been meaning to play this game for a while and I'd really like to actually be able to!

Here are the details:
I got a bunch of mods from the vault, all of them went in the override folder in documents, and made a few throwaway characters to check whether everything was working. It was. When I made my actual character, the one I meant to play through the campaign with, the above problem of loading screen freezing started. I don't think I messed with any mods between the throwaways and the actual character, though I might be forgetting. Interestingly, this problem does not occur if I choose a premade character from "select character" rather then creating my own. However, if I do start with a premade the game crashes when I try to save it. I have since removed all mods from the override folder and done a full reinstall of the game, but the problem persists. I've checked that the override and hak folders are both empty. I am clean out of ideas and I'm as sure as I can be that my game install is clean and shouldn't be causing problems, yet problems remain. Help please?

TLDR: campaign loading screen freezes if I make my own char, trying to save crashes if I use a premade, problem remains even though I reinstalled.
This question / problem has been solved by Valkinazimage
Try removing all mods for start. It still possible that you messed something up.

What sorts of mods have you used? Are there any companion edits? Like Romance pack or something
First I would delete the Documents\NWN2 folder and let the game create a new default one when you start a new game.
Then I would right click on that folder and choose properties>security and see if your username has full control.
Also, if you are on Windows 10, make sure your Documents folder hasn't been relocated to Onedrive.
Post edited September 11, 2017 by olnorton
avatar
Valkinaz: Try removing all mods for start. It still possible that you messed something up.

What sorts of mods have you used? Are there any companion edits? Like Romance pack or something
I've already deleted all mods and done a full reinstall of the game. In theory, it should be in the exact state it was when I first downloaded it.

The mods I used were a bunch of redone textures, NWN2 fixes, and a dll file that fixed the movement stutter bug. They were working fine for a while... I can't figure out what caused things to go wrong.
avatar
olnorton: First I would delete the Documents\NWN2 folder and let the game create a new default one when you start a new game.
Then I would right click on that folder and choose properties>security and see if your username has full control.
Also, if you are on Windows 10, make sure your Documents folder hasn't been relocated to Onedrive.
Did not work.
I have full control.
Documents hasn't been relocated.
Post edited September 11, 2017 by nfritsch
avatar
nfritsch: I've already deleted all mods and done a full reinstall of the game. In theory, it should be in the exact state it was when I first downloaded it.
What are your gpu and what settings have you set for game(grothics mainly

For choppiness you'd be better using this rather then standalomne dl
https://neverwintervault.org/project/nwn2/other/nwn2-client-extension
avatar
nfritsch: I've already deleted all mods and done a full reinstall of the game. In theory, it should be in the exact state it was when I first downloaded it.
avatar
Valkinaz: What are your gpu and what settings have you set for game(grothics mainly

For choppiness you'd be better using this rather then standalomne dl
https://neverwintervault.org/project/nwn2/other/nwn2-client-extension
graphics card is a geforce gtx 860m.
I haven't changed graphics settings from the default after reinstall, before it I had turned everything up to max.
I've now downloaded that client, but it hasn't done anything for the main problem.
avatar
Valkinaz: What are your gpu and what settings have you set for game(grothics mainly

For choppiness you'd be better using this rather then standalomne dl
https://neverwintervault.org/project/nwn2/other/nwn2-client-extension
avatar
nfritsch: graphics card is a geforce gtx 860m.
I haven't changed graphics settings from the default after reinstall, before it I had turned everything up to max.
I've now downloaded that client, but it hasn't done anything for the main problem.
Looks ok. I heard there are some problems with radeon

Hmm... How much free space do you have on disk? Nwn2 require around 3.5 free space during runtime
https://pcgamingwiki.com/wiki/Neverwinter_Nights_2#Running_on_a_non-primary_partition.2Fhard_disk

Try free up disks a bit and do defrag. Might be the sourse of problems
avatar
nfritsch: graphics card is a geforce gtx 860m.
I haven't changed graphics settings from the default after reinstall, before it I had turned everything up to max.
I've now downloaded that client, but it hasn't done anything for the main problem.
avatar
Valkinaz: Looks ok. I heard there are some problems with radeon

Hmm... How much free space do you have on disk? Nwn2 require around 3.5 free space during runtime
https://pcgamingwiki.com/wiki/Neverwinter_Nights_2#Running_on_a_non-primary_partition.2Fhard_disk

Try free up disks a bit and do defrag. Might be the sourse of problems
I've got like 300 gigs free, it's not that.
avatar
Valkinaz: Looks ok. I heard there are some problems with radeon

Hmm... How much free space do you have on disk? Nwn2 require around 3.5 free space during runtime
https://pcgamingwiki.com/wiki/Neverwinter_Nights_2#Running_on_a_non-primary_partition.2Fhard_disk

Try free up disks a bit and do defrag. Might be the sourse of problems
avatar
nfritsch: I've got like 300 gigs free, it's not that.
Thats strange... Maybe its notebook gpu indeed... Do you have another gpu in notebook? like intel one? Can you swittch to another one for a test?

I personally use windows 10 and I have no problems starting game apart from small choppiness which extender fixed so I doubt its system problem... Also try turning off all effects in nwn2. Will it help load or still no luck?
avatar
nfritsch: I've got like 300 gigs free, it's not that.
avatar
Valkinaz: Thats strange... Maybe its notebook gpu indeed... Do you have another gpu in notebook? like intel one? Can you swittch to another one for a test?

I personally use windows 10 and I have no problems starting game apart from small choppiness which extender fixed so I doubt its system problem... Also try turning off all effects in nwn2. Will it help load or still no luck?
Making it run with the intel card didn't do anything, nor did turning off everything I could in graphics optiions.
Strange is the word for it alright... I can't imagine what could be causing this.
avatar
Valkinaz: Thats strange... Maybe its notebook gpu indeed... Do you have another gpu in notebook? like intel one? Can you swittch to another one for a test?

I personally use windows 10 and I have no problems starting game apart from small choppiness which extender fixed so I doubt its system problem... Also try turning off all effects in nwn2. Will it help load or still no luck?
avatar
nfritsch: Making it run with the intel card didn't do anything, nor did turning off everything I could in graphics optiions.
Strange is the word for it alright... I can't imagine what could be causing this.
Is it instlled in "Program files"? Pulling last straw I can think for now
avatar
nfritsch: Making it run with the intel card didn't do anything, nor did turning off everything I could in graphics optiions.
Strange is the word for it alright... I can't imagine what could be causing this.
avatar
Valkinaz: Is it instlled in "Program files"? Pulling last straw I can think for now
It's in program files x86.
avatar
Valkinaz: Is it instlled in "Program files"? Pulling last straw I can think for now
avatar
nfritsch: It's in program files x86.
Thats actually might be the source of problem. Nwn2 doesn't like UAC, so you may want to try and reinstall it outside this folder
avatar
nfritsch: It's in program files x86.
avatar
Valkinaz: Thats actually might be the source of problem. Nwn2 doesn't like UAC, so you may want to try and reinstall it outside this folder
Reinstalled in a different location, still doesn't work. This makes no sense to me.
Solved it!

It was my antivirus-- it had decided that the neverwinter nights 2 folder in documents was protected, and wasn't letting the game create any new files in it. Like save files, for instance. It would make the folders just fine, but couldn't put the actual data in them. Anyway, I've told the antivirus to allow nwn2 to change stuff in the folder and everything works again.