It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

ResidualVM, the wrapper that adapts Myst 3, apparently has hidden parameters that cannot be fixed when they become mal-set. Following a presentation of my evidence, I'll detail the issues & settings.

I've run Myst 3 with the following resolutions:
640x480 windowed
1280x720 windowed
1280x960 windowed
1280x720 (no scaling), black-matted in fullscreen 3840x2160
1280x960 (no scaling), black-matted in fullscreen 3840x2160
1920x1080 (no scaling), black-matted in fullscreen 3840x2160
7680x4320 (scaled), cropped to fullscreen 3840x2160

'myst3.ini' provides 3 directives that pertain:

widescreen_mod= // ... 'true' or 'false'
fullscreen= // ... 'true' or 'false' (false ==, windowed)
fullscreen_res= // ... example: '1280x720'

Especially note that there is no 'window_res=' directive (I tried it... doesn't work).

Rhetorical Question: If there is no 'window_res=' directive, how was I able to change 1280x960 windowed to 640x480 windowed? Well, I did this:

<--- previously was 1280x960

then ran the game. Then this:


then ran the game.

That put Myst 3 in a 640x480 window.
I have not been able to get it into a larger window since then.

That is not correct behavior.

Given the settings in 'myst3.ini', none of the resolutions I listed in paragraph #2 make any sense.

Further, this is screwing up Windows' feable (and awful) autoscaling.

Currently, my Myst 3 is
1280x720 (no scaling), black-matted,
Windows is not scaling,
the mouse 'finger' is too small to see on a 3840x2160 display, and consequently,
the game is unplayable.

I can't express how frustrated I am with this situation. I've been fighting this for days.

Regarding Windows scaling, here are the combinations -- I tried them all.

Program DPI
[_] Use this setting...
[I signed in to Windows]
[I open this program]

High DPI scaling override
[_] Override high DPI...
[System (Enhanced)]

If you, dear reader, have any ideas, bring them out!

Warm Regards,
Post edited September 09, 2018 by markfilipak
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have an UPDATE

The problem was: Poor documentation leading to misunderstanding leading to bad configuration.

Background: My games run on an NVIDIA GPU. My laptop has a 2nd GPU: an Intel GPU, but I don't use it for games (or so I thought).

As it turns out, the NVIDIA connects only to the Display Port, on the side of the laptop. I don't use an external monitor. I use only the laptop's built-in display, and it's the Intel that connects to that. Apparently, this is the way most gaming laptops are engineered.

So, if the NVIDIA connects only to the Display Port but I don't connect an external monitor to the Display Port, then what good is having a fancy NVIDIA GPU?

Answer: Lots of good. Windows uses the NVIDIA as a graphical coprocessor to create images in the same manner that it uses an arithmetic coprocessor to do math. The only thing that the Intel GPU does is drive the built-in display and scale the desktop to fit it.

It's that second task that took me by surprise.

I figured that, because the game was 'running' on the NVIDIA GPU, I needed to go to the NVIDIA Control Panel to get it to scale fullscreen. When I didn't find any controls to do that, I thought my NVIDIA Control Panel was broken.

Well, the scaling settings are in the Intel Control Panel (which I never even looked at). I posted problems to Intel & Microsoft & NVIDIA forums. Everyone on those forums were mystified. The only documentation I could find talked only about multiple displays.

It was one technician at NVIDIA who gave me a clue that lead to the solution to my game scaling problem. It seems that everyone (except that one technician) practices NMP (not my problem).

For all the details, see
Post edited September 14, 2018 by markfilipak