It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Pretty much the topic title...

Bannerlord is, as of this posting, at version 1.5.8 here on GOG.
I was looking to try out some mods, specifically the "Calradia Awakens" fantasy setting mod, but can't run it on anything higher than version 1.5.6 or maybe even 1.5.5.

I've tried going to Bannerlord in my library > Extras > and disabling automatic updates, but the only versions that appear on that list are 1.5.8 with varying hotfix patch version.

I don't see any way to revert all the way back to 1.5.6. As far as I understand Steam can still go back to all those older versions.

What are my options in GOG? Any way to go that far back?
If not possible in GOG any way to get a previous version from Talesworld site or even get a Steam key from them?


Alternatively, if anyone has tried the Calradia Awakens mod have they found a way to get it working on 1.5.8? When I try to launch the game with that mod it claims to use up an absurd (like near infinite) amount of memory and crashes out.
Post edited March 28, 2021 by Kolrath