It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Is anyone else having a speed bug in MK3 where the character select screen is basically in fast forward? I can barely move 2 squares and the game picks a character and the character select voiceover also gets cutoff.

Also, I could be wrong, but is the game supposed to play as fast as it does? It almst reminds me of Street Fighter II Turbo.
That was a problem even during Win 98 days. What I've been doing with the DOSBox version was simply putting the game in OpenGL rendering and putting some filters on it to slow it down a little. And the game was quite fast and I don't remember any problems there. It's hard to say though what you may be experiencing.
However I think that MK1 CD version (the one on GOG) plays a little faster than floppy and arcades though.
Same bug over here, really annoying, but other than that no complaints.
I'm sure GOG can fix it though..
As I mentioned in another thread - one option is reducing DOSBox cycles for the time of character selection and then restoring them back (Ctrl + F11 and Ctrl + F12, after setting the cycleup and cycledown to more appropriate values in dosboxMortalKombat3.conf file).
I found that setting a fixed cycle count of 40,000 solved the problem. Game still runs great as well.
Bought it today on discount, encountered the same problem.

The game comes with DOSBox 0.74, while there is a newer release 0.74-2 which lists the following change:

Windows: Fix auto/max cycles algorithm on Windows 7, which helps with stuttering audio.

So I tried updating bundled DOSBox to 0.74-2 and also to the latest SVN version, but it didn't help. Only manually setting cycles (via keyboard or in config file) helped, as said previously.
1.- Go C:\Program Files (x86)\GOG Galaxy\Games\Mortal Kombat 3
2.- Open with Bloc Notes dosboxMortalKombat3.conf file
3.- Change the value of CPU Cycles. Auto--->40000
----
Before:
core=normal
cputype=auto
cycles=auto
cycleup=1000
cycledown=1000
----
After:
core=normal
cputype=auto
cycles=40000
cycleup=1000
cycledown=1000

4.- Save
5.- Fixed
Post edited September 25, 2019 by N3griazul11