It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I downloaded the game file and installed the game. At the end of the installation GOG installer gives me the option to immediately launch the game - I do and it works fine. I played the tutorial then I went and chose a warband and play the game as intended. The problem is the second time I try to play the game.
The second time I played the tutorial again, it was fine. Then I try the "New Warband" and the interface took me to the screen where you get to "Choose your warband" just like I did on my first run. Here is the problem.
I click on a character -he screamed, the little white comet at the bottom right corner blazes away for a few seconds and then stops and nothing else happens. I tried the same with all the characters but the game does not load.
I can go back and it takes me back to the previous page. It does not crash or anything of the sort. It just does not let me chose a warband.
I thought that maybe the Windows Defender is blocking something after it was installed, so I re-installed the game and also ran the game as an administrator (as some suggested as I went online looking for solutions). I even added the executable "mordheim.exe" under the allowed application through Windows Defender firewall. Still the same issue.
I deleted the game again and installed through GOG Galaxy. I encountered the same problem.
I have over 600 games on my library (no, I have not tried all of them but many of them through the years) even other Warhammer titles like the last one I tried “Battlefleet Gothic – Armada” and it plays fine. Yet, this game was installed like all the others but is giving me this problem.
No posts in this topic were marked as the solution yet. If you can help, add your reply