It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I noticed that everything runs too fast in the Might and Magic games. The animations run too fast, and the mouse is sluggish. I looked around a bit, and I read that slowing CPU cycles down might help, and I read that a new DOSBox might help.

I don't know anything about DOSBox, so I am lost at what to do. I tried lowering CPU cycles, but it seemed to make the games run worse.

Does using a new DOSBox help with this problem? If so, how do I get it? What do I need to do to get it to work with the game?

This happens in MIght and Magic 3 through 5 that I noticed so far, and it also happens in other DOSBox games I bought off the site. I realize now that it's impossible to enjoy these games with this big problem. Please help!
No posts in this topic were marked as the solution yet. If you can help, add your reply
(EDIT: I think the best option is to try getting the newest version of DOSBox and see if it helps, check the end of the post for details on that.)
Kadlin: I don't know anything about DOSBox, so I am lost at what to do. I tried lowering CPU cycles, but it seemed to make the games run worse.
Did you do this through DOSBox? DOSBox has a special way to change the number of cycles and it should change the game speed. While the game is running, press Ctrl+F11 to lower the cycles and Ctrl+F12 to increase the cycles. Lower cycles should run slower. The current number of cycles is displayed in the bar at the top of the DOSBox window. Switch to windowed mode by pressing ALT+ENTER and then look at the bar at the top of the window to see the cycles... then use Ctrl+F11 and Ctrl+F12 to dial them around and see if it helps.

If you find a cycles setting that you like, there is a way to tell DOSBox to always start with that number of cycles. I can explain how to do that if you want.

It seems that for most people, MM3-5 run at a good speed without having to change cycles though. MM1 is the only game with a serious speed problem (it runs WAY too fast) but there's a fan fix for that game which you can find in these forums. A few people had an issue with the mouse in MM4 and MM5, check the thread here:

A newer version of DOSBox might help. The games come with DOSBox version 0.72 but the current version is now 0.74. You can download the new version and just install it over the old one, I believe. Get it here:

I believe that GOG will have installed DOSBox to your game folder (so it will be inside the folder where you installed the MM pack) so if you just download and install the new version in the same location it should run the new one.

Hopefully one of those things will help you out!
Post edited July 02, 2011 by Waltorious
Play around with the dosbox cycles. Pressing ctrl-F11 and pressing ctrl-F12 is easy enough. You'll find a value for which it works well soon enough. I'd try about 3,000-10,000 cycles. It's possible that two totally different values work well while the average of both might not.
Thank you very much for the help :).

I got the new DOSBox, and I believe I did it right. When the game is running, I use ALT-Tab, and it says 0.74 at the top.

To be honest, I really don't know much what I'm doing with all this stuff. The CPU cycles wasn't working before in Might and Magic World of Xeen with the original included DOSBox. It was in a percentage instead of numbers like the other games, so I edited the dosboxMM4-5.conf file with stuff from Might and Magic 3, and now the CPU cycles does work.

All the Might and Magic games are still running way to fast for me. Also the mouse in them all is very sluggish. Using the newest DOSBox doesn't seem to help, the games still have the same problem.

So now I can lower the CPU cycles to levels where the games run more normally, Lord Xeen doesn't laugh a mile a second anymore, but when I lower the CPU cycles, the mouse becomes even more sluggish, to the point of it not even being playable. The mouse already lagged, but now it lags even more.

I guess if there was a way to make the mouse stop being sluggish, it would fix this issue. Is there anyway to fix a lagging mouse?
If 4 and 5 are running too fast, there may be something wrong with your computer. Unlike earlier games, the Xeen engine is throttled: even if there are spare cycles, it still shouldn't be going too fast. MM2 and 3 weren't throttled, however, so on any modern computer they'll speed out of control: lowering the cycles will help there.
MM1 was also unthrottled, however it does have some adjustments for time, but used a very old DOS function rather than the clock: it expected this particular function to take some length of time and generated all of its delay around that time frame. DOSBox handles that function internally, very fast regardless of cycles, so even slowing down the cycles won't do much for this. There's a patch that makes it use a fixed timer instead of this particular function.
Ah, I remember now. The looping animations in the Xeen engine are unthrottled. Most of the game is throttled just fine, it's just some animations that go too fast. Guess that could cause some people a problem.
Kadlin: I guess if there was a way to make the mouse stop being sluggish, it would fix this issue. Is there anyway to fix a lagging mouse?
One thing I forgot to suggest... try changing the graphic mode. There should be a little program that GOG made called "Graphic Mode Setup" that will be in your game install directory and also possibly in your start menu, in the same place as the MM games. Try different settings for this. The usual ones to try are "surface", "direct3d" and "opengl". Sometimes changing those will help with weird graphics issues and it might help with your mouse lag.

Other users report that mouse lag existed in the original games, though, so there may be only so much you can do.

By the way, you did indeed install the latest version of DOSBox correctly. Even if it hasn't helped the problem I recommend keeping it because it supposedly has better compatibility with more DOS games than the previous versions did.
Nothing really wrong with the computer I don't think, I don't touch anything on it. It's just the DOS games that all run super fast, World of Xeen was going a mile a minute, Lord Xeen laughed at super sonic speeds, and I tried walking forward one step and ended up going 3 steps. I tried reducing the cycles in Realms of Arkania 2, another DOS game I bought from the site, and it works good in that one, with the mouse's movement staying smooth. So I know it's something in the Might and Magic games that is causing a mouse lag.

They say the mouse lag may be an original game issue? Oh that's not good. I noticed that increasing the CPU cycles to 20,000 makes the mouse lag less, but at the same time, there's still a lot of lag there. I tried all the video modes too, and it was the same in each.

Hmm, not really sure what to do. Got the fast stuff figured out now(sorta), but I can't play the games with the mouse lag, it'll sore my eyes after not too long :(. Thanks for the suggestions and help, it's a bummer that I might not be able to play these games.

I have a quick question, is it possible to play Might and Magic 3, World of Xeen, and the Swords of Xeen, all with only the keyboard? Is it relatively an easy task? I think that may be my only option.
The games should be playable even better with keyboard.

After starting dosbox you can type "install" in the mm3 and xeen game folder to select a different sound card. This can also affect mouse lag.

You can also change cycles during the game to slow down/speed up when you need slower/faster speed if nothing else helps.

I didn't have any problems with mouse or speed playing MM3, both with dos on my old PC who was much faster than required and with dosbox.

In WoX the mouse pointer did work a little worse, but I had no problem with it.
Kadlin: Lord Xeen laughed at super sonic speeds, and I tried walking forward one step and ended up going 3 steps.
Hmm, that's weird, and definitely not normal. If the cycles are too high, Xeen's laugh animation will be really fast, but it'll just loop as it plays the audio at a normal speed. Or should, anyway.
Actually, there may be something up with the Xeen config itself. I've never run the games from the actual GoG install, I just install the games and then dump them into my own DosBox environment. I'll have a look.
Thanks :).

Yeah, I'll have to play with the keyboard I think. Oh well, I don't mind!

I'll try the different sound card and see how it works.
Kadlin: I'll try the different sound card and see how it works.
If it doesn't, you should try changing the graphics mode using the little program GOG provides for that purpose. It's a super-quick test, just try switching between Surface, Direct3D, and OpenGL and see if it makes any difference.

I think the sound card setting is a more likely culprit though.

And yes, keyboard-only is definitely possible and preferred by many players. The only time you might want a mouse is when doing inventory management and stuff but even then there are keyboard shortcuts for everything, and they're probably faster than a mouse once you learn them.
Still no luck. I tried the different sound devices, I even set it to none, and the mouse lag was still present. Tried the different graphics modes too with the same result.

Can't get rid of this mouse lag no matter what I try it seems. It's like I'm getting really low frames per second in the games, which in turn causes the mouse to lag, if that makes sense. For example, at the beginning in Swords of Xeen when the servant of pharaoh is talking, the mouse lag is heavy, jumping around the screen. After he finishes talking and the game goes to the 3D movement view, the heavy mouse lag stops, but there is still considerable lag. It's like the mouse lag happens heavier at certain times, and other times it's still there but not so laggy.
Kadlin: Still no luck. I tried the different sound devices, I even set it to none, and the mouse lag was still present. Tried the different graphics modes too with the same result.
How did you change the sound devices? Did you do it through the .conf file or did you run the "install" program in the Xeen directory and pick a different sound device from there?

Both are worth a try. I think that running "install" is the best option but you may want to also go into the .conf file and make sure that the settings there match what you set in the install program.

Running the install program can be a little tricky because you need to do it from within DOSBox, at a dos prompt. But you need to make sure that everything in mounted in DOSBox the same way it is when you run the game. The easiest way to do this is probably to use a .conf file edit. If you go into the .conf file, there's a section at the end called "[autoexec]" which shows several commands that are run when you start up DOSBox. Now, before you make any edits be sure to back up the .conf file. Anyway, at the very end of the file in the [autoexec] section you should see the last two lines reading:


Just delete those, and be sure to save the file afterwards (this is why you kept a backup, so you can revert if necessary). Then run the game's shortcut normally, and everything will mount but you'll be left with a DOS prompt because it ran everything EXCEPT launching the game. Then just type "install" at the prompt and you'll get the install program. From there, you can not only pick different sound devices, but also set their Port, IRQ and DMA settings. Try changing these, the IRQ especially, and see if it helps at all. Remember that you may also want to go to the "soundblaster" section of the .conf file and change the settings there to match the ones you picked in the install program.

When you're done running the install program and fiddling with the .conf file, youwill probably want to exit DOSBox, then run the shortcut again. You'll get the DOS prompt again, just type "xeen" to launch the game and test it out.

I hope that helps! Sorry if you already know this stuff, I figured I'd spell it out just in case... it's not exactly intuitive unless you're used to using DOS.
I did it in the config file before, I had no idea how to do it otherwise. It seems to work that way, changing the sound in the config file does change the sound in game(much easier way to do it for people like me, haha). I've done everything using the config file only since I found out about it.

Thanks for the explanation! I deleted those last 2 lines in the [autexec] part of the config file, but the DOS screen didn't come up. The DOS window would appear for a second and then disappear. Is there anything else I have to do? I haven't messed with anything else, other than using the new vesion of DOSBox, everything else is kept the same as I installed it.

This DOS stuff is really frustrating. I'm not use to using it, I was only a baby when these games and DOS was around. Thanks for the continued help though! I appreciate the effort in helping me try to get it to work right.