It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've just encountered this recently, and after a search for any other topic on it, I thought I'd mention it.

It appears that MM7's item collision sizes sometimes has problems with some of the large shields. My character's inventory page "looked" like it had enough room, but as I tried to store the shield, the character first said, "I have no room" followed by the game crashing. But wait, it gets worse... if the game doesn't crash, be aware that that character's inventory page is now corrupted. Items like a potion will have a six square collision, instead of two, and other strange things like that.

Don't exactly know what's causing it, since I've never encounter a problem like this before.
That's odd.

I can't say I've ever had (or heard of) this problem.

Have you installed any of the patches mentioned in the sticky thread?
I'm pretty sure I installed the patch for mm7. I'll check again.
I double checked... I had patched mm6 but not mm7, so I did get it updated to 1.6.2. The patch didn't mention anything about inventory problems, but it hasn't happened again since patching. Of course, I'm a bit more careful.

Thanks for the reminder! 8)
Post edited November 12, 2012 by Foucter
OK. After continuing my game, it is apparent that something is still amiss, but at least it's not crashing the game. I emptied my Paladin's inventory, and tried putting his tower shield in the middle of his pack. It gave me an error tone, and popped it to the far left side of the inventory screen as if that area still contained an item, making the shield not fit there.

It's strange, but not totally unmanageable. I still think it's tied to the large shield's storage footprint, which can be hard to tell if you have enough space to place it. So I would be aware.