It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I've encountered chests in Warlord's Fortress that I seem to have to pick. I thought there wasn't a lockpicking mechanic in MM6. How can I open them?
No posts in this topic were marked as the solution yet. If you can help, add your reply
With a key?

Only one chest should need a key - at most, I cannot quite remember if it does, or if instead the door to the room it is in needs a key. I seem to remember finding two keys together - one unlocks something important, and the other goes with a singleton from somewhere else to open a double-locked door to somewhere nice but not important.

What I have discovered is that several of the chests, spread over about three different rooms, are all one and the same - I call that a bug. Maybe you've discovered a variation of that bug.

Unless, like skull piles, some of the chests need expert perception to open? All my characters already had that for a chance to duck if my disarm trap fails.
Post edited August 19, 2018 by RSimpkinuk57
hmm tnope here isnt lockpicking in mm6
so you may have to find the keys for those chests
they should be somewhere in there
i think i remember a storage key in that dungeon

sadly my current save isnt that far into the game
so it may be a while before i can get there to check it out direcly

edit: alright my save was further along than i thought
all the keys seem to be in waist tall cabinets
and i managed to loot all the chests no problem
so all you will need to do is keep looking for the keys and you will be good

Post edited August 19, 2018 by Vyraexii
Two keys are needed to get into the storage room that has some minor items in it (and a bunch of barrels). The "Warlord's Key," which you get at the same time as one of the storage room keys, opens the chest with the "Discharge Papers," which is the proof of having defeated the Warlord.
I have the keys to the storage room and have looted it. I have found all the keys (according to online guides) and if you don't have a key, you usually get the message that it's locked. Here it specifically says "You were unable to pick the lock" as shown in the attached screen shot.

I have also tried with both Master Perception and Disarm at skill level 14 and it still doesn't work.
Wow, that's weird ... never seen anything like it before.
This must of been left over after s design decision was made not to have lock picking.
(Look at me pretend I know this stuff. But it doesn't make sense otherwise.)
macAilpin: This must of been left over after s design decision was made not to have lock picking.
(Look at me pretend I know this stuff. But it doesn't make sense otherwise.)
I've got the same issue. Interesting that the only reference to this is quite recent (summer 2018). OP, do you have the greyface patch installed? Wondering if those chests were added by the patch, sometimes it adds content that was blocked off in vanilla.
Anyone happen to have worked out how to open these, by any chance? It's the first time I've ever seen them too, 99.99% sure that they were never locked previously.

I do have greyface installed, but I have played through a few times over the years with it installed, and never noticed this. Some of my fav chests in the game heh.
Could this be a low-probablity outcome from the random contents generator for chests? An alternative way of giving nothing at say 1 in 500 chance., the Marcelais-Pike "walk-through" (crib book, I'd call it) marks "5. Chest (unopenable)" in the east of the Sweet Water map. Well when I played that chest did open and held loot in the ordinary way.
Post edited January 16, 2019 by RSimpkinuk57
Im surprised also. The guide Im following (15 years old, lol) doesnt say anything about chest or closets that you cannot open. Since there is no lockpicking I wont waste my skill points finding it out :)