It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Which version of World of Xeen are you playing? We have two: the floppy version and the CD-ROM version.

What version of Windows are you playing it on?

Do you have UAC(User Account Control) turned off?
Nickcronomicon: Hi and thanks for the quick answer. I'm playing the version from the M&M6 limited edition that I bought here at GoG. I forgot to mention that I'm playing it on Windows 7 64bit. Any other game from the package seems to be in correct working condtion.

I'm not sure on UAC, Where might I find this?

I just checked and it also happens whenever I leave the tavern, or any 'shop' of that matter.
We offer two versions of M&M 4-5 WoX in our M&M 6 Limited Edition, hence the reason I asked which version you are having issues with :D Have you tried the full speech version and vice versa?

UAC we can forget about for now since that mostly causes problems during installation and my suggesting turning it off was a derp moment on my part. Mea culpa.

How are you running the game? Are you running it from the Start menu or are you running the executable that the GOG shortcut refers to? Are you running it as Administrator?
Post edited January 14, 2013 by JudasIscariot
Nickcronomicon: Ah I see :) Well I'm running the full speech version as far as I'm concerned. At least some of the characters are voiced so. How can I start the other version since I don't really see it. I'm launching it now from the game directory itself. Yes I tried running it as an administrator!
edit: Well, I was trying to solve this but you did it before I finished typing :D.

edit #2: You're welcome :D
Post edited January 14, 2013 by JudasIscariot