It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello I just downloaded the Might and Magic 6 pack and verything is cool so far, but I cannot have 3,4 or 5 on full screen that actualy cover my whole screen....I have tried to switch thing arround and so far I got the window to run in the center of the screen. I know this is possible because other gog games do run fullscreen, for example 6 runs full screen (with black bars on the sides) on my game.
Also I read some other comments how to setup the games to run with the roland emulation, but for some reason the methods I tried for the 4-5 and Swords of Xeen (by changing the ini stetting on the dosbox) dont work for 3 because the install exe just goes dead...
Any help is highly appreciated
No posts in this topic were marked as the solution yet. If you can help, add your reply
MM3-5, which run on DOSBox, should not have any trouble going fullscreen... in fact, that should be the default behavior from a fresh GOG install. On my machine, they run fullscreen with black bars on the sides, because I have my graphics card set up to scale while preserving the aspect ratio.

You mentioned that MM6 runs fullscreen with black bars, but MM3-5 do not. What happens when you try to run them fullscreen? Do you just get a small image in the center with black all around? Or does it just run windowed, with your desktop still visible?

Normally I'd say you need to set your graphics card scaling options, but if MM6 works then that's not the problem. It's possible that your display can't go to a low enough resolution; what kind of display do you have? Are you using a laptop or a desktop? The games run at a pretty small resolution so that could be the problem.

Some things you can try in the DOSBox config file (located in the install folder, called dosboxmm3.conf or similar): First, make a backup copy of the file. Then, open in a text editor and do the following:

Find the line that says "fullresolution=original" and change it to your screen's native resolution, for example "fullresolution=1920x1080". This might get the game to fill your screen, but it also might stretch the image. Alternatively, you can play in windowed mode, but make the window bigger. Find the line that says "windowresolution=original" and change it to something higher, like "windowresoloution=1024x768". This makes the window fill up more of your screen. If you want the game to start in a window, change the line "fullscreen=true" to "fullscreen=false". Or you can switch it yourself after launching the game by pressing ALT+ENTER.

Sadly, I don't know about getting Roland emulation working. Post back and let me know if any of that helped get the games to run fullscreen though.
I did some fiddling arround with the setting and now they are showing up correctly, thanks for the tips man!
No problem, glad you got it working!