It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

It doesn't seem the issues I'm having have been touched upon yet although I might be missing them. As of recently I have to turn off the intros for both games as both games will crash if I don't do this. This didn't use to happen so I'm not sure why all of the sudden this is going on. Also the setup options for both games will not let me select hardware acceleration at all. It says for both that my cards don't support this so it goes to software acceleration. I have 2 ATI 5870's.
You may have to disable Crossfire on the ATI cards to get the hardware acceleration option.
I had the same issue, you can either turn off the intro or right click on exe file > Properties > Compatibility > Run in 256 Colors. This fixed my issue at least. Still can't alt+tab out of the program thou.