It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello all,
I've bought the game yesterday,I thought it was going to work without any hitch what so ever,and that all the major issues were resolved seen as it is on GOG.
Well unfortunately there is some serious artifacts issue which makes the game unplayable , you can't even see your own character or it's surroundings.
For example at the start of the game the second character polygon are "merging" with your characters polygons and in the other part after you blew up the box and enter the lab its all black or your char is gone and you can only see whatever you hold in your hand.
I've tried everything:
1.Making a shortcut on the desktop with the "+!" or "+!" "-p" methods and Compatibility mode with win2000 98 XP 95,nothing seems to work.
2.Trying to patch the game didn't work either it can't find the game folder.
If anyone wants the patch it's in this Link:
It also have some trouble shooting which didn't work either.
3.Tried any possible configuration in the "VIDEO Settings" menu of the game non helped.
Anyone have a solution for this?
For what it's worth I did some 3d modeling for a time and this problem seems to be related to the the Rigging/Skinning envelope IE the char texture envelope that supposed to hold it in place does not act properly,maybe it can be fixed by playing around with Directx?
As an example the game Jedi Knight MOS have a similar problem where all the textures goes whack and it been fixed by putting the DDRAW.dll in the game folder(they did something with the ZBUFFER).
I've been able to fix several other problematic games mainly from solutions from other community forums but this game doesn't seem to have any.
I've attached some pictures for bug examples.
merge.jpg (34 Kb)
bug.jpg (72 Kb)
Post edited December 26, 2009 by GameDesigner
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well Apparently user "badSector" have found a working solution in his post-
I've tried everything except this..
The solution in simple steps(with small change to the user badSector one)-
1.Make a shortcut to the file "MessiahD3D.exe" on the desktop.
2.Right Click the Shortcut and On the Shortcut Details add -x after the game directory as in:
"C:\Program Files\\MessiahD3D.exe" -x
3.On compatibility tab change to Win98 (although it worked with out it but it might be safe to leave it on)
4.Run the game Select resolution from the window
5.A game resoultion selector will appear again,pick the following-
Direct3D HAL(No T&L)
The same resoultion as you put in the previous window with 32bit mode.
And the game works without any artifacts ,the only thing is you can't see any videos playing just hear them for some reason..
Well it's better that then non playable game..
Thx bedsector on the useful solution
below is the original problem that I had:

Spread the word! :D