It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
skpicky: Your link worked great for me. Now do you have one for Spearhead and Breakthrough?
Well it takes a minute to do..

http://guu.fi/g/moh_spearhead.exe
http://guu.fi/g/moh_breakthrough.exe

I did not test them. Please tell me if they work for you.
All, just downloaded MOHAA. At first it crashed right away. I tried the opengl32.dll thing and now it goes a little farther into the process before I get a message GLW_StartOpenGL() - could not load OpenGL subsystem. The process stops there and you have to quit. I have it running as administrator and in compatibility mode. Win10 on an ASUS board standard graphics card.. Ideas???
I was having trouble getting the Spearhead and Breakthrough expansions to run without crashing on start, but I found a simple solution on another forum that got them both to work. I'm going to post it here in case anyone is having the same issue. Also disclaimer: I've never had a problem getting the main Allied Assault game to run.

1. Go to the game folder

2. Rename MOHAA.exe to something else. I always do something like MOHAA_original.exe.

3. Rename the Spearhead or Breakthrough exe file to MOHAA.exe (ensure only one MOHAA.exe in the game folder at a time)

4. Whenever you feel like switching to the other expansion or back to the main game, repeat the same process.

For whatever reason, the expansions won't run unless their exe file is named MOHAA.exe.

Credit to LordVader888 on the Microsoft Answers forums for this one.
Post edited July 29, 2018 by Kontarek