It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So I had this game on Origin for the longst time, and it worked perfectly fine. Then one day, out of the blue, the game refused to launch. I tried almost every fix I could think of, and I could never get it to launch. So I eventually just uninstalled, and reinstalled, just to see if it would fix itself. It did not.

So now, I decided to get the GOG version of this awesome game, hoping that it's better optimized due to GOG's reputation of having quality games that work. That is not the case it seems, as it does the EXACT same thing with the GOG version.

So what happened was that when I finally was able to download the game on a 300kbs internet speed, it installed, but then there was some kind of error that popped up, with no explanation as to what kind it was. So after I click launch, screen goes to black, and the loading icon of the mouse cursor kees spinning, till I have to quit the black screen by hitting Esc.

I have wasted SO many freaking hours trying to fix this game on my laptop, I'm at my wits end.

As I'm typing this, I tried to verify and reair the game to see if that helps. It did not, and instead produces the same error from when I installed the game. Image is included for anybody to see what the cause is.

If anybody knows how to fix this, PLEASE tell me! I REALLY want to go back to playing these awesome games that hits all my nostalgia buttons.
Attachments:
No posts in this topic were marked as the solution yet. If you can help, add your reply
Try to run the game in compatibility mode.
Right click on the game exe, select "Properties" then choose the "Compatibility" tab: there you can find the compatibility modes (Windows Xp SP3 should be the more appropriate, but try others too if necessary).
avatar
dr.schliemann: Try to run the game in compatibility mode.
Right click on the game exe, select "Properties" then choose the "Compatibility" tab: there you can find the compatibility modes (Windows Xp SP3 should be the more appropriate, but try others too if necessary).
Did not work, I even tried this with the Origin version. I ended up using the opengl.DLL file in the windows 8 fix(using windows 7 btw), and that seems to have worked, but now the graphics are a bit wonky at times, and the main menu is kinda borked up.

I might have to eventually do a complete system repair just to see if that even fixes it completely, because I'm at a loss.
Having trouble myself. Even put on directx 2010 version. run in xp sp2 and 3....nothing works.
Let me clarify.....I ran the main program fine. The two expansion packs do not work.
Post edited November 14, 2016 by delaceyd
avatar
delaceyd: Having trouble myself. Even put on directx 2010 version. run in xp sp2 and 3....nothing works.
Let me clarify.....I ran the main program fine. The two expansion packs do not work.
At least your main game works. NONE of my games refuse to launch. They just end up crashing at start up.
I've had this game crash too, but it was so bad that I couldn't back out of the blank screen. No Task Manager, no Windows Start Screen, nothing. Had to hard-restart my PC.

At any rate, I want a refund. This is the first time a GoG game I've bought disastrously didn't cooperate with Windows 8.1. I couldn't be more upset that a game I've waited a decade to have the hardware to play it at all, and now it doesn't boot, if not risks damaging my system.

This makes me worried about buying anything else with the expectation that other old PC games I liked were properly patched to run on modern Windows OSes. Compatibility is the entire appeal of buying on GoG for me, versus Steam. If I have to expect more games to not work right away, I'll just keep my business on Steam.
avatar
johnluke728: I've had this game crash too, but it was so bad that I couldn't back out of the blank screen. No Task Manager, no Windows Start Screen, nothing. Had to hard-restart my PC.

At any rate, I want a refund. This is the first time a GoG game I've bought disastrously didn't cooperate with Windows 8.1. I couldn't be more upset that a game I've waited a decade to have the hardware to play it at all, and now it doesn't boot, if not risks damaging my system.

This makes me worried about buying anything else with the expectation that other old PC games I liked were properly patched to run on modern Windows OSes. Compatibility is the entire appeal of buying on GoG for me, versus Steam. If I have to expect more games to not work right away, I'll just keep my business on Steam.
I have the same issue. None of mine will launch. Has anyone found a solution to this?
So I guess there is still no fix for my problems then.....damn it.

I REALLY wanna play this nostalgic childhood favorite, and it just refuses to work on windows 7, and nobody has even helped me.
avatar
lunchboxx1990: So I guess there is still no fix for my problems then.....damn it.

I REALLY wanna play this nostalgic childhood favorite, and it just refuses to work on windows 7, and nobody has even helped me.
I'll see if i can give you a hand.
I bought my gog copy recently, but i'm still using my old copy from CD install eons ago.
So i may not have all the exact files as yours (yet).
I'm running on Win7 64-bit.

Looking at your original posting screenshot, is the game really installed ?

The error message is in a box with "Setup" in the corner. This makes me think it's trying to run the install exe instead of mohaa.exe

If it's really fully installed, what happens if you just try to run the game from the folder it's installed in ? (Outside of Galaxy).

If you don't know or can't tell if its really installed, from explorer make a shortcut to the setup_medal_of_honor_2.whatever.exe. Then with a right mouse click set the shortcut to run in compatibility mode (XP-SP3) and toggle the "Run as Admin" flag in the shortcut too.

Install it wherever(someplace else) and it should be set.

Then before launching the game, go to that install folder and run 'Configure.exe" (I'm assuming its still included).

Let me know how that goes and we'll see if or what else we can do.

Pete
avatar
lunchboxx1990: So I guess there is still no fix for my problems then.....damn it.

I REALLY wanna play this nostalgic childhood favorite, and it just refuses to work on windows 7, and nobody has even helped me.
im having the same problem as you. how is it going? have you got it fixed yet? im might be in the same laptop spec as you, windows 7, intel hd graphics right?

i bought the games lots of times on gog, this probably the game that doesnt work. bummer
What steps have you taken to ensure your problem isn't caused by the infamous GL extension string bug that plagues most old quake engine games?

http://guu.fi/g/MOHAA.exe

I just played the training & first two missions on Linux and it runs great.

And yeah first thing first, take galaxy out of the equation and just start the game directly.
Post edited June 11, 2017 by clarry
For me it fixed deleting newconfig.cfg in main folder (This file is created by configure.exe) and deleting file unnamedsolder.cfg in main/configs folder,but i have some menu issue menu is not aligned properly and and while shooting between my click and shooting in game is 2 seconds delay i dont know why so if you know abot this issues something plz tell me.
Attachments:
If you have intel graphics card, that's the issue. It won't work. I loved this game when it first came out so when I saw it here I scooped it up. Unfortunately, I have an intel HD2000 integrated video card. It actually works pretty well but for whatever reason, this game will not work with it. Other games, like Fallout 3 say it won't work but there are workarounds and I can play it fine. I got a refund. Rather play the game. :(
medal_of_honor_series/crash_to_desktop_fix_resolution_help_and_config_tweaks - its on GOG
(find this forum)

followed this forumand it fixed everything up.
Post edited January 27, 2018 by wizzygoats
avatar
clarry: What steps have you taken to ensure your problem isn't caused by the infamous GL extension string bug that plagues most old quake engine games?

http://guu.fi/g/MOHAA.exe

I just played the training & first two missions on Linux and it runs great.

And yeah first thing first, take galaxy out of the equation and just start the game directly.
Your link worked great for me. Now do you have one for Spearhead and Breakthrough?