It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Darkeus: I am having the same issues. Every time I try to run the patcher, I get a "can't start because can not find MFC71.DLL" error. I am slightly familiar with what this error entails but I can find NO information on this even though the problem has happened to many people.

They just have no solution or link to some site to download .dll files. Lol, no thank you.

So, since I am sure some people have had to run into this issue trying to patch the mods, can I get some help please!! :-)
avatar
PAK: I managed to solve this out. First, I dl'ed those missing dll's (in my case there were two of them) - just google them and for sake of security install them manually (in winxp - copy them into system32 folder iirc). Second - I realised that I was trying to use older version of those mods. In mediafire sort those files by the date of the modification and download the latest. I managed to run the latest tropical without a problem. Some additional info can be found here:
http://grogheads.com/forums/index.php?topic=6576.30
But be warned - work on those mods apparently was stopped, but they are not fully stable. I was playing with tropical and strawberry, iirc, and later in the game crashes (directx layer error) started to occur when browsing the colony list (in my case it was when I had 20 or 30 colonies). I didn't found any remedy and stopped playing.
Yeah, I meant to update this. I finally got this to work myself. I found the .dll file from a forum user here and then found a patcher that worked. Lol, it was not easy but I finally prevailed.

Thank you very much for your response though!!
Where can I get this tropical mod 1.22? I always find only 1.21 and the 1.3.10?
avatar
Maxvorstadt: Where can I get this tropical mod 1.22? I always find only 1.21 and the 1.3.10?
All versions of tropical mod can be found at http://www.mediafire.com/?bab6i5ezwj6u1
Is tropical 1.38 ready for prime time? Which mod should I go with for Moo3? I'm looking for true to original intent as possible.
I got the game working fine under win10 with the tropical 1.21 mod.

I'm also curious about the state of mods. Are the new versions a significant improvement, and are there any new mods worth trying out?
It's a little confusing to navigate the pros and cons of the various fixes and mods available :D
avatar
abbayarra: Is tropical 1.38 ready for prime time? Which mod should I go with for Moo3? I'm looking for true to original intent as possible.
Down load Bhruic's MoO3Patcher and the Patches that are Listed as patches. There are Some that are listed as Mods.

There is a >DLL 1.67 that Must be installed 1st before you can apply any patch. The .DLL makes the patches usable.

The Location for getting this MoO3Patcher is. LINK is Bad.

This system fixes all the major "bugs" that Quicksilver and Atari let ride thru. It makes MoOIII enjoyable and very playable for those that did not give up on III. It is also the base for all the Mods posted/talked about here in previous posts.

I personally have a Mod listed at The Master of Orion Guardian site http://www.moo3.at/ . It is called the Random Gov't mod. Many of the Mods posted about are also found at the Guardian. Plus many of the early Mods for III. Otsego's Diplomacy Mod is a Must have. His Otsego 0.85 is also a very good Mod coupled with using bhruic's Patcher.

Been playing and modding MoOIII for 13 years now. Was a very active AtmoO forum member for almost 7years (before Atari pulled the plug on us! :( )

The Gog version here will take all these Mods and the Patcher. When I upgraded to win 10 x64 my original CD set would not work. So I bought Gog's version and put it to the test. Works just fine on win 10 x64.

JosEPh (AtmoO Keeper of The Roll Call)
Post edited April 05, 2016 by JosEPh002
avatar
JosEPh002: [

The Location for getting this MoO3Patcher is; http://bhruic.dyndns.org/patcher/downloads.php
This address is now a jobs-listing site...;)
The links in this post are no longer links for patches, etc. I know there's a lot of of information on the
the " guardian" site. and even Bhruicpatcher link is no longer works again. But there is patch list that has 1.25 file.
Is this the same???? On this patch list page there's "data patch" & "code patch" Are these needed at all???

Okay, I am a dummy when it comes to modding. Do all these patches go just in data file or MOO3 main file???
AND the mods again in MOO3 data or main file???

If you can please give a step by step process to get this stuff done.

Thanks,

jmk

PS I see the explanation on page 1 of this post; I don't know why but when I clicked on post I was always taken to page 2; and I din't see this was page 2 AND there was a page 1!!! sorry. I am going to have to read the page one stuff numorus times, because I don't understand it all. BUT, BUT I do need to know what , where the patcher file is; the links on this post do not work; you get something not even about MOO3.
Post edited April 04, 2016 by jmkile
avatar
JosEPh002: [

The Location for getting this MoO3Patcher is; http://bhruic.dyndns.org/patcher/downloads.php
avatar
waltc: This address is now a jobs-listing site...;)
It was good a month ago. I suppose I could add it to my Dropbox acct and post that link once I get it set up.

WG was going to contact Bhruic thru Tom Holsinger about "possibly" adding his Patcher to the MoO3 released with the Collector's Edition. BUT here at Gog they just gave you a discount for the CE if you already had MoO3 from Gog.

I have not had any further news to the progress for getting the MoO3Patcher included. Perhaps with the link going down, being switched there is movement in this regard. Then again it could be that the MoO3 Player from Germany that hosted the Patcher for years has sold his site and moved on.

JosEPh
Post edited April 05, 2016 by JosEPh002
[url]www.lcs-hamburg.de/Bhruic/bhruic.dyndns.org/patcher/index.php.htm[/url]

This link is the Proper Link for the MoO3Patcher and Patches.

It does not work from this post, just copy it to your browser, you may have to actually write it down though. ;)

JosEPh
Post edited April 05, 2016 by JosEPh002
Okay, I found an old site for bhruic stuff, BUT this site has really old downloads on it!! Like newest one is from
2010. Patcher is .51. I presume this is not latest.

So, I am going to ask again, where and what is the latest patcher file; is it on the Guardian site. If one clicks on "patches" from left column on Guardian site, there are 2-3 patches, for windows and mac; Is this what is needed??
Because I don't see any "patcher" file on this site. There is a listing in projects for this patcher file but again it's not working; always directs you to a sales site. So, again I ask where and what is the patcher file I need??

Thanks, for all your time and answers.

jmk
avatar
jmkile: Okay, I found an old site for bhruic stuff, BUT this site has really old downloads on it!! Like newest one is from
2010. Patcher is .51. I presume this is not latest.

So, I am going to ask again, where and what is the latest patcher file; is it on the Guardian site. If one clicks on "patches" from left column on Guardian site, there are 2-3 patches, for windows and mac; Is this what is needed??
Because I don't see any "patcher" file on this site. There is a listing in projects for this patcher file but again it's not working; always directs you to a sales site. So, again I ask where and what is the patcher file I need??

Thanks, for all your time and answers.

jmk
See my post right above yours for the Proper Link. You will have to manually put in your browser. Since I could Not figure out the url settings for this forum.

the link is: www.lcs-hamburg.de/Bhruic/bhruic.dyndns.org/patcher/index.php.htm . Please read the replieds and post above you for needed info.

Enjoy
JosEPh
Okay, so, if you're new to the game, what is suggested ? Tropical 1.21 ?
avatar
Splatsch: Okay, so, if you're new to the game, what is suggested ? Tropical 1.21 ?
I would use Vanilla 1st to get used to basic game play mechanics. Then you could try Strawberry or Tropical as they change lots of things around.

If you can find Otsego 0.85 Mod it's a good one too.

A simple Mod is my Random Gov't used with just Bhruic's MoO3Patcher and base Parches (not the "Mods/Patches")

JosEPh.
avatar
JosEPh002: I would use Vanilla 1st to get used to basic game play mechanics. Then you could try Strawberry or Tropical as they change lots of things around.
Okay ! When I'll try the game (certainly not before some time), I'll get this way :)
And I'll try the other mods after playing a little Vanilla with main mods.
Thanks !