It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Sorta a wierd problem so not quite sure how to correct it. The mouse will move but I can't click on anything. Therefore cant start a game cause cant click "new game" in the main menu. As I said the mouse moves around but can't get it to do anything. The game loads though Dbox and seems to start fine other then that. Any help or suggestions would be appreciated
Try to tab out, back into dosbox and maximize view, now the game should accept clicks,
once it works you can switch back to windowed mode.
If not successful hit [N] for "new game" a couple times.
If that also does not work i am sorry, you have to wait for a hopefully working solution.
avatar
townltu: Try to tab out, back into dosbox and maximize view, now the game should accept clicks,
once it works you can switch back to windowed mode.
If not successful hit [N] for "new game" a couple times.
If that also does not work i am sorry, you have to wait for a hopefully working solution.
Ok it sorta works - the N wil start a new game but mouse wont work in fullscreen mode
alt-tab and windowed screen I get the mouse to work but I cant remember how to get back to full screen again or make the windowed screen bigger - really small screen is very hard to see
avatar
Polne69007: Ok it sorta works - the N wil start a new game but mouse wont work in fullscreen mode
Try to do some keyboard input first (say press enter) while in windowed (no need to change) after start, it should do the trick for the session (in case its exactly the same thing i encountered, and from what you did wrote, chance is good).
Post edited April 14, 2017 by DarzaR
You can do Alt+Enter to switch between Fullscreen and Window Mode.
And you can edit your Dosbox Config to make the window bigger. Easiest way with Galaxy by clicking on More -> Other -> Graphic Mode Setup. There dsable Fullscreen and set screen resolution in the Advanced Settings Tab. If you dont want to do this, you need to use a Texteditor and edit the Config per hand.

I have the "Mouse problem" when switching, too. Whenever you press any key that is bound to a command, the mouse will work again. I still prefer window Mode, as i can see notifications of other programs and easily switch between them when needed.
Right clicking IN the Dos window has helped me lock the cursor into DosBox.
avatar
Themken: Right clicking IN the Dos window has helped me lock the cursor into DosBox.
thanx for all the help got it to work
This should be stickied or even better fixed by GOG. I have the same problem as the topic starter.
Post edited May 06, 2017 by Tarm
DOSBox has more severe bugs but this one is annoying until you learn to live with it. There is even a key assigned to locking mouse into or out of DOSBox. This copied from the manual of DOSBox:
"MOUSE: The mouse doesn't work.

Usually, DOSBox detects when a game uses mouse control. When you click on the screen it should get locked (confined to the DOSBox window) and work. With certain games, the DOSBox mouse detection doesn't work. In that case you will have to lock the mouse manually by pressing CTRL-F10."
Post edited May 06, 2017 by Themken
I've got something similar going on, but with MOO (MOO Classic? I'm too old...)

I can't get the mouse to work whatsoever - pressing CTRL+F10 just causes the Windows cursor to appear and disappear, but DosBox doesn't recognise it whatsoever. "Locking" the cursor just means it vanishes, unlocking reveals the windows cursor again with no result.

It worked at one point, but about three or four weeks ago it just stopped.

Mouse controls work fine in other GOG games - just checked ST25th, for instance.

Kind of baffled, to be honest, as I didn't futz with the config before it stopped working.
The "autolock" setting in the DOSBox .conf file might help some of you. It's in the top-most ("sdl") section, just under the window and resolution settings. Set it to true if it's not already set to that.

Also, of course, you could just play the Win95 version. The filename is Orion95.exe. I believe that it's included. It's just that GOG's installer adds only icons for the DOS version, perhaps because, out of the box, the Win95 version has a misaligned mouse cursor. That can be easily solved by the fix in the the following thread, though:
https://www.gog.com/forum/master_of_orion_series/moo2_win95_mouse_fix
Post edited July 06, 2017 by jnisbet