It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I bought the MOO1&MOO2 pack last month. I played a MOO1 game as the Meklar one night and saved the game.
The next day, I tried loading that saved game and it returns me back to the starting screen.
So I tried the Continue option and the game crashed to a black screen.
So effectively, I can only play Master of Orion 1 so long as I don't turn off or try to do anything else on my computer.
Is this a known bug?

I'm running Windows10 64-bit with latest drivers.
avatar
plasmatime: I bought the MOO1&MOO2 pack last month. I played a MOO1 game as the Meklar one night and saved the game.
The next day, I tried loading that saved game and it returns me back to the starting screen.
So I tried the Continue option and the game crashed to a black screen.
So effectively, I can only play Master of Orion 1 so long as I don't turn off or try to do anything else on my computer.
Is this a known bug?

I'm running Windows10 64-bit with latest drivers.
Oh dear! Sadly I cannot help you but here is a hug to comfort you, not being able to play MoO is awful.
avatar
plasmatime: I bought the MOO1&MOO2 pack last month. I played a MOO1 game as the Meklar one night and saved the game.
The next day, I tried loading that saved game and it returns me back to the starting screen.
So I tried the Continue option and the game crashed to a black screen.
So effectively, I can only play Master of Orion 1 so long as I don't turn off or try to do anything else on my computer.
Is this a known bug?

I'm running Windows10 64-bit with latest drivers.
I have the same problem with MOO2. I have not tried to see if the same thing happens with MOO1.

I might add that support by GOG was less than helpful.
You have gone through the basic trouble-shooting for DOSBox games, like NOT installing the games into the program folder(s).
Did you both try re-installing MoO1 and 2 from/thru Gog?

And did you set admin rights?

JosEPh
I had this same problem. After reading some other suggestions, O Checked to see that my Start was "As Admin".
I also checked the Properties, and found under the "Security Tab", the Permissions were mostly Blank. After I Edited to set all to Full Control, including the Two that are labeled Interactive, I am able to Open Saved Games, Change Map Size, Number of Opponents, and other options. Hope this will help others with game load issues.
I checked the Properties section and all were set to Full Control already and the game does have Admin privileges.

I clicked on Manage Installation -> Verify/Repair and it made 9 updates.
I loaded MOO1 and it worked perfectly. :)

The game is slow to load and there is some horrendous lag.
If I select a ship and then a plan for it to go to, then hit ok. It takes a good 4 seconds before I see the ok button depressed, then a few more before it's done with that.
I would think on modern computers that these sorts of things would be faster now. Guess not.
CTRL + F12 to raise cycles to over 4000 (5000 should be very smooth).