It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'm having a strange issue trying to get Lords of Magic SE to run on my machine (Win7 64-bit, nVidia GeForce GTX 1080). The game appears to launch correctly, but a few seconds into the first movie splash screen (the Sierra logo), the screen freezes and no longer updates, but I can hear the game continuing to run in the background, albeit at a stop-start rate. (Imagine if you were watching a Youtube video and somebody was pausing the video every half-second before hitting resume.) Attempts to alt-tab out and back in again either result in the game crashing altogether or simply screen-freezing again on whatever screen the game is currently on.

Has anybody else experienced this, or have any ideas what could be causing this issue?
Following some further testing, I've noticed that if I launch LOMSE and then immediately alt-tab out, the game running in the background no longer seems to suffer from the stuttering. Therefore, I think the issue may have something to do with the resolution or display. Is there any way to run Lords of Magic in windowed mode so I can test to see if that's the cause?
I have a similar issue where I can launch the game but I get a black screen. Then if I alt tab to something else, then tab back into the game, I can see everything again. However I still have issues with stuttering in game and graphical glitches. This is on windows 10.
Just stumbled into this issue myself, but alt tabbing does not work. I just can't ever get the LOMSE window to display again, but the audio keeps going and keystrokes register because I can definitely hear it skip to the main menu.
Returning to let everyone know what the fix was.

Apparently any program that has an in game overlay can cause this issue. For me it was GeForce Experience messing me up. Unfortunately that particular program has no real option to turn it off, so I ended up having to uninstall it. Not ideal, but at least I can play LOMSE now.
avatar
cidbahamut: Returning to let everyone know what the fix was.

Apparently any program that has an in game overlay can cause this issue. For me it was GeForce Experience messing me up. Unfortunately that particular program has no real option to turn it off, so I ended up having to uninstall it. Not ideal, but at least I can play LOMSE now.
Thanks for your answer! For me it was RivaTuner Statistics Server via MSI Afterburner.

Closing both or adding "lomse.exe" to the "Application detection level" "None" worked.