It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just bought this game, and installed it using the offline installer of the latest version 2.0.5. Unfortunately, it's impossible to start a new game, since it get stuck forever on the loading screen when I select "New Game". I also get a popup at startup about needing an app to open a Discord link, which is slightly annoying although not a major issue by itself. I tried many things like running the game as admin, fiddling with the game options, plugging in a controller, and nothing changed. I even checked with Process Monitor to see if the game was trying to access some missing resource, but I found nothing.

The same problems have been signaled by a few others in the Changelog thread months ago. Was there really no fix or update during all that time?

I'll submit a support ticket to GOG as well, just in case.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Yeah... I just bought the game and have run into the same problem, and I also see in the other post that the issue looks like it's been going on for months. I'm going to be honest here. GOG shouldn't been selling shit that doesn't work. It's pretty much theft.
I've been in contact with GOG's support team about this. As it turns out. the Discord requirement is the cause of the problem. Having a Discord app opened allow the game to function normally, and it's not even necessary to log on Discord. If Discord is installed but not active, the game actually shut down immediately before even reaching the title screen.

This might work as a workaround, but I'm not satisfied with this, as it means that this game require either an Internet connection to run, because Discord won't start without it, or Galaxy to roll back to an earlier version, since the issue have appeared in the latest update. Both these things are unacceptable to me.

I have also contacted Semisoft, the developers of the game, but so far I have received no answer from them. Maybe it's just because of the upcoming holidays. Then again, others have reported this issue months ago and they haven't fixed it yet, so it's not looking good.

I would not got so far as to call it theft. This seems more like neglect from the developers' part, a thing that is sadly too common here. We can always ask for a refund from GOG if necessary. I do agree that GOG should pull out this game from the store until it's fixed, though.
Post edited December 21, 2019 by Dantre
Well, I do run Galaxy. I didn't even realize you could roll back to an old version though. I went to the previous version and the game runs at least. So, thanks for that info anyway. You are right that that's not really shouldn't be required though.
The game was updated, and the latest version have solved these issues.

Kudos to GOG's support team for resolving this. They dealt with it quickly and efficiently once I submitted a support ticket to them, especially considering the current holidays.