It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey Guys!

I'm having an issue with Lands of Lore 2 at a specific point in the Huline Jungle Village when you first meet Baccata. Just as he finishes his first line of dialgoue and Luther is supposed to speak, the game crashes.

I receive the following error message from within DosBox:
Memory allocation of 1309694 bytes failed!! MemAvail: 1319788 Largest: 1244084

I've tried changing mostly all the settings in DosBox and have... well given up! If somebody could help out I'd be most grateful! Here's a link to the save game where the problem occurs, if somebody wouldn't mind testing it that would be great!

System Specs:
Windows 7 64-bit
Nvidia Geforce GTX 460 SE (Latest Drivers)

Thanks in advance!
Post edited November 27, 2011 by BaconUK
This question / problem has been solved by Aurelius_Maximusimage
You aren't the only one. I am getting the exact same error in the same place.
willi5x: You aren't the only one. I am getting the exact same error in the same place.
add one more
But... as i found out you may play on and choose the path of killing the kings guard and meet Baccata outside the village afterwards without running into a crash.
Well, as a test I replayed the game from the beginning. I skipped the Draracle Museum, headed straight to the cave in the Huline Jungle where you find the little girl and her mother and finally travelled back to the village and spoke to Baccata. It worked!? The error didn't appear. So I'm guessing maybe the save game can get corrupt somehow?
Post edited December 05, 2011 by BaconUK
I ran into this problem to. Starting a new game worked for me, but it's still an annoying bug.

Do GOG put out patches to fix problems like this?
Post edited December 06, 2011 by Stian83
Same issue here. sadface :-(
I was wondering if any of you guys happens to have a savegame from that point that's not corrupted. If you do and are willing to share it, please contact me via PM on forums.
Got the same problem, but managed to play around it. I downloaded the original game (disc iso's), installed it and loaded the savegame from the GOG version. Played through the Bacatta part in the orinigal version, saved and switched the new savegame back to the GOG version.

After this didn't have any problems anymore. But it is a lot of work to get around the problem.
Are there any savegames or solutions for this problem yet? I'm completely stuck atm :/
I've gotten around it by using my old Windows version of the game to view the cutscene. Saved past that point, reloaded in the GOG version and it worked.
Problem with that is...I don't have the original version :(

*edit* Jarkeld was kind enough to take my savegame and play past the crashing part for me. I'm putting my savegame online for other people with the same problem:

Next step after loading the savegame is visiting the monastery.

To team: since this most likely just corrupted gamedata, is it possible to check your Lands of Lore 2 installation files and maybe release a "fixed" version later?
Post edited March 17, 2012 by Boeboe
yeh seriously fix this, first game i play in awhile i really start getting into and tada fatal error
Was there made any progress on this matter?
I honestly believe this is a DosBox problem because I played through this game many different times on many different systems with the DOS and Windows starter and different patches as well. This part was never a problem.
Post edited July 26, 2012 by ShardofTruth
Oh wonderful. I finally get to this game afte all these years and - there is a crash bug so I cant play, a bid odd GOG selling game which have obvious functionality problem without warning:-/