It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Have Win10x64, R9 380 4GB, and Crimson 16.3 drivers, and the stock installation from GOG for Win10 doesn't use any compatibility modes except "run as admin" and "Disable display scaling for high dpi settings."

I am also using nGlide 1.05 (latest version). D3d in-game won't display the cut scenes and seems very unstable.

Running it that way, I get the "not enough video ram" error displayed in-game whenever I transition between areas--like leaving Gladstone and entering the forest, or leaving the forest and entering the docks, etc. The game also crashed 2x for me with the GOG compatibility

I added "WinXP (service Pack2)" into the compatibility settings mix (and unchecked disable display scaling on high DPI settings), and the game seems to run consistently now with no crashing (the GOG version is the Win95/WinNT version of the game)--but I still see the "Not enough video ram" error displayed prominently whenever transitioning between locations.

Anyone else see this, and I'm wondering if anyone has had better luck with the D3d version of the game.

This fixes the Video ram error completely: -CD. -16MB -NO_ASSERTS -WEAK add this to the lol.exe shortcut and it's gone!
Post edited March 17, 2016 by waltc