It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So the color palette isn't to bad it's just a few colors here and there especially black. The battlefield is alright, the units are mostly alright and the side bar (oil) and main menu is a little hard to read. It's mostly anything black is the wrong color. Also every screen flickers constantly.

Any suggestions? I think someone mentioned for KKND2 to change the resolution in the config file but KKND doesn't have one titled config.
Quite a few old games have this problem now.

This is what helped me in other cases:
1) Kill explorer.exe before playing. You will have to start it again when finished so you can look for a batch file online that does this automatically.
2) You can try downloading and running this:
http://aok.heavengames.com/blacksmith/showfile.php?fileid=11108
It is for Age of Empires 2 but it worked for me in other games.
3) If you have NVIDIA Optimus then it may be the cause of the screen flickering. Had the same problem with another game. Not sure what to do with this.
Alright I solved the flickering by telling the nvidia control panel to run all programs of the cpu but the color pallete is still wrong.
If either the fix or killing explorer.exe did not help with the colors then I am not sure :(
If you are using Windows 7, try opening up Screen Resolution, then open Advanced Settings, keeping both windows open... Now run Krush, Kill & Destroy.

This trick worked for M.A.X.2, Fallout, Fallout 2, and Interstate '76 maybe it'll work with the KKND games.
Colors fixed now. In compatibility settings tick all boxes except for disable visual themes and disable desktop composition.