It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

PKodon: I think the problem is that the program that's available to do the patch doesn't run on current versions of Windows. I'm not sure what version it does run under, but I wouldn't be surprised if it ran under Windows 3.x. Too bad there isn't a DOS version of the patch, that would make things a lot simpler.
I'm not sure if that is the problem, check this link
A guy made an installer to work with new PC systems, patch included, and works with a lot less bugs than the gog version.
I'm not sure if this helps, but Sierra left some good technical updates and hints for their games here:

Hope you find anything useful - anyway it's a good place to check if you're getting any old Sierra games, as they have a lot of help and solution updated for modern computers.

- Sam
I am still experiencing this error. I have downloaded the game several times and contacted gog support twice with no response since the "support guy" responded to these posts.

Does anyone have a solution? It looks like gog is selling a bum product and not bothering to support it.
I'm suffering this whenever I get into specific fights in Chapter 4, same error and everything, and seriously, this isn't fair. It's been over a year and a lot of people here cherish the game... :(
Post edited December 01, 2011 by AstraKiseki
Same here. Its a bloody shame this game is not patched
Bump. Not really interested in moving on past chapter 1 until that temple shows up. not too happy with GOG right now....
I'm not bought anything from since for about 2 years now. I'M NOT BUYING ANY MORE GAMES TILL THIS GAME PATCH FIXED. Any one else please post your support on here and commitment not to buy anything from them till it's fixed. Send GOG an email to get in gear and fix this game(if they have, tell me).
Same here. I joined GOG specifically for this and one or two other games.

There have been several deals that have really made me want to purchase more from them, but I will not until this game is patched.

I joined Steam about the same time I joined GOG, and have found them to be much better about this sort of thing. They are getting my money right now and GOG isn't.
I got an email from support on Nov 17 as a response to my support problem submission -

" support

Nov 17


We're currently working on a fix for the known issues with BiA. I'll let you know as soon as a solution is ready."

This issue has been known for quite some time, I just think they are just not going to fix the game.
Post edited December 17, 2011 by JaCook1956
Same for me, not buying any games until they fix it. If they're taking their time, so am I. Spread the word.
I just got a reply that they are working on it. I tried to move on a little bit more and in chapter 2, in order to get to the secret gold mine behind the Farmer's house, you HAVE to go through his fields but you can't go through the fields because the staff is there poisoning his fields and the only way to A. get the staff which is an awesome weapon and B get to the gold mine is to get blessed at that damned temple, so again....stuck.

If there is some huge problem, I don't know why they just don't tell us that but I can't imagine its that hard to find the missing temple files and patch the game .... or if there is some other corruption as to why the temple files are being re routed to that empty field ....
wich game is it betrayel at kondor or that other?
WTF I joined so I could play this game and one other. Do they offer refunds? This is no different then selling a car with an engine that explodes after 20K miles. How is this remotely reasonable that they are even selling this game is this condition?

I'm done with GOG. This is BS.
I installed the game pack to my 2 gig USB stick and then tried to patch thre game with the 16-bit patch on a older computer - did not work. The patch failed due to "internal file size mismatch" or some other strange reason - The .exe file must be a different size than the patch expects due to changes by GOG.... (It was worth a shot)