It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Splatsch: I hope that next time, when you'll finally play it again it'll be with as few issues as possible this time !
Well, for next time I have DRM-free copy from Humble Bundle so it should be, probably, some different code.
avatar
Lexor: Well, for next time I have DRM-free copy from Humble Bundle so it should be, probably, some different code.
Oh ok :)
I hope it will be flawless then ;)
avatar
Lexor: This topic is old, maybe it's fixed.
avatar
Splatsch: I just wanted to install the game with a fresh downloaded offline installer, and game main menu says it's "build 34,387".
Sooo... I haven't followed exactly all this story, but... isn't this an outdated version which, if I understood well may contains still some bugs ?

- Should I install the patch's files from OperationKordar.rar as suggested here ? https://www.gog.com/forum/kings_bounty_series/gogs_kings_bounty_the_legend_v1_7_build_35396_has_some_serious_bugs/post33
- Or use Atari's .exe which is build 35234, as suggested here : https://www.gog.com/forum/kings_bounty_series/kings_bounty_the_legend_reverting_to_version_16/post5 and https://www.gog.com/forum/kings_bounty_series/kbtl_how_to_load_the_game_after_the_upper_hadar_solution/post5
- Or simply contact GOG's support (or 1C publishing ?) to ask them if there could be an official update of the game ?
- Or play the game and wait to see if I encounter a bug ?
I managed to finish the game with the Atari executable, everything worked fine both Upper Hadar and the Necromancy skill
Post edited November 28, 2018 by drk84x
avatar
drk84x: I managed to finish the game with the Atari executable, everything worked fine both Upper Hadar and the Necromancy skill
Okay, I'll use it if I encounter an issue then :)
Thanks for your feedback !
avatar
Lexor: This topic is old, maybe it's fixed.
Nop.

I found the thread through internet search, found it quite strange couldn't talk to some NPC but thhought it could be some random quest...
After found Lina's fountain, spent 1/2 hour trying to get around why wont work, had to resort to internet...

Don't know wich version I'm playing but it's the last one since I installed the game a couple of months ago.

Thanks for the help in 2019. Cheers :D
Post edited October 16, 2019 by Dark_art_
avatar
klaymen: How is "showflyingdead" supposed to work now? I have reinstalled the game to try it out and it shows either damage or killed units, not both. Setting "showflyingdead" to 2 shows just the casualties.
avatar
Lexor: After Firek's patch, setting 2 and starting the game will revert it to 1 and works like that (= casualties). I wonder if, for example, Steam version acts the same. Can someone check that?
Yoo, I was reading about this topic since I had this same bugg. I have KB TL bought on steam. I had showflyingdeath first set to 0(automatically?). This is my third time playing this game and its the first time encountering this bugg. Normally I would see damage in the yellow ish color and the death amount in red(both at the same time but not at the same place in the screen) so basically it was working perfectlty. But now fort some reason it only showed damage before and I managed to change showflyingdeath to 1 but can not change it to 2 for some reason? When I start the game it changes it back to 1. I saw Lexor being online so i decided to ask even after 9 years XD. I just wondered if you still remember what you did to fix this bugg.
avatar
johnfromtokyo: But now fort some reason it only showed damage before and I managed to change showflyingdeath to 1 but can not change it to 2 for some reason? When I start the game it changes it back to 1.
From what I read in my first post value of 2 is a buggy one, so it's good for you to not be able to set it.
avatar
johnfromtokyo: But now fort some reason it only showed damage before and I managed to change showflyingdeath to 1 but can not change it to 2 for some reason? When I start the game it changes it back to 1.
avatar
Lexor: From what I read in my first post value of 2 is a buggy one, so it's good for you to not be able to set it.
Google translate:
I wrote to the 1C publisher by mail a week ago about the errors of the "upper Hadar", and the publisher replied that the developer had sent an update that fixes the errors. Therefore, the game should already be updated and the bugs will be fixed. The game must be updated to version 1.7.35.398.

1C asks me if the errors are fixed, and I have to send them an answer. Bugs fixed?
Post edited July 30, 2020 by Aleksandr.Mgn
avatar
Aleksandr.Mgn: 1C asks me if the errors are fixed, and I have to send them an answer. Bugs fixed?
I'm rather not going to install KB again, but:

1) As I can see the last update for this game on GOG is from October 11, 2017.

2) Here is the post from October 16, 2019 (two years later):

avatar
Lexor: This topic is old, maybe it's fixed.
avatar
Dark_art_: Nop.
avatar
Aleksandr.Mgn: 1C asks me if the errors are fixed, and I have to send them an answer. Bugs fixed?
Unfortunately I can't test it out as the offline installers have not yet been updated (I don't use Galaxy) - support said that it should be "available soon". I'm looking forward to another play through so when GOG do upload the new installers I'll check it out.
avatar
Aleksandr.Mgn: 1C asks me if the errors are fixed, and I have to send them an answer. Bugs fixed?
avatar
Pajama: Unfortunately I can't test it out as the offline installers have not yet been updated (I don't use Galaxy) - support said that it should be "available soon". I'm looking forward to another play through so when GOG do upload the new installers I'll check it out.
Thanks for the answer. I hope the bugs have been fixed and there will be no more problems. It's strange that it was only fixed after my complaint. It seems that no one has written to them about this error.
Post edited July 30, 2020 by Aleksandr.Mgn
the offline installer for windows (eng) has been updated to 1.7.35.398

unfortunately I will not be able to test the proposed fix for a while, as I do not have any savegame
Post edited July 30, 2020 by liPillON