It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The majority of the game's text outright isn't displaying for me.

I'm using Windows 7 64x bit, apparently I should downsize my font but it's at the smallest size by default.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have the same problem! First the game worked normally, as it should. Then it always crashed whenever I tried to launch it because it doesn´t like VLC Media Player(no comment...). I re-installed, read in the forums that some programs may cause it not to start up.
Now it starts up again but it always tell me I should set my font size to small- where? how? There is no such option in the game menu and changing vista font to small isn´t possible, there is only normal and large.
All text on event screens etc. is missing completely.
Solved, for now :-)
Sensenschmied: Solved, for now :-)
In case someone else has the same problem, do you recall what you did? Or did it involve sacrificing to Malia so you don’t want to admit it?
No, no there are no thralls in this village. There never were. You must confuse it with some other village. Now go away!

Anyhow, nah, no idea why it is working now. To be honest I think it´s just because I restarted the PC. While I had those issues I did re-install the game, but did not restart the PC. No idea how such a thing can be fixed by a reboot, but PCs are magic to me, anyway, so...
Post edited May 31, 2013 by Sensenschmied