It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I cannot get this to display on my primary monitor. It just keeps showing up on my secondary. Cannot find any setting to correct this.
Same problem here. Game automatically starts on my secondary monitor instead of the primary.

Just found an improvised fix. Use ALT+ENTER to go to windowed mode and then put the game window on your preferred screen. Go back to fullscreen mode and select your preferred resolution. It's not ideal but it works. Would be nice to have an in-game option for this though,
Post edited July 17, 2017 by Deadyawn
I also have the same issue,its annoying and the only game I have ever had with this problem. Glad I only paid a few dollars for this otherwise I would be asking for a refund if I had paid full price. Please fix it, devs.
On Linux the settings file is in '/home/username/.config/unity3d/Thunder Lotus Games/Jotun'.
File 'prefs', line '<pref name="UnitySelectMonitor" type="int">-1</pref>'.

On Windows it is in registry: 'HKEY_CURRENT_USER\Software\Thunder Lotus Games\Jotun\'.
Post edited August 14, 2017 by boo007