It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

In Nvidia controle panel under "Adjust desktop size and position" under 2. Apply the following settings:"
1. Tick the "Aspect Ratio" box
2 There is a drop down uder it. It's called "Perform Scaling On". There are 2 options:
1. Display (that's the default)
2. GPU

In the dropdown menu select the GPU option to let the GPU do the scaling instead of the monitor. This should allow proper scaling of Jazz Jackrabbit 2 on a 4k display. My TV is set to 4096x2160 @ 60HZ. I'm using a GTX 1660. It works fine. If I use the Display option it is overscanned and all 4 edges are cut short.

Not even chang desktop res. to 1920x1080 would work.

I get the correct scalling and aspect ratio from the game. The GPU also has Integer Scaling. I just went with aspet ratio to keep it simple.