It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

At some point in the game you'll find yourself in a harbour. Part of this phase takes place next to a big warehouse. For me there was an issue here. After walking past the big sliding door and completing all puzzles and tasks "on the left", the idea is to walk back right and enter through the sliding door.

When I tried that a bug would occur: Jack stopped walking very soon (or not even appear on the screen), the cursor disappeared and the game would not really crash, but lock up and not let me do anything any more (in-game, the menu still worked). If the same happens to you, maybe my solution will also work in your case:
- When passing the sliding door for the first time (walking to the left), open it (but don't go inside)
- Continue walking to the left as you would normally do
- (solve the puzzles blah blah blah)
- Walk back to the right, for some weird reason, the bug won't occur
- Go inside

Hope this helps someone!