It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
FeelingShred: Your guide there is spot on, thanks for the hard work man!
I just want to add something that sounds dumb I know but this totally happened to me last year... If you did everything for the game to work and it still runs too fast or have physics problems, try restarting your computer. (this is not a joke) Someone out there will be able to provide a more detailed technical explanation, but the CPU gets tied with the executable, restarting frees the CPU from those ties...
Correct. Even after getting the game up and running, I came across this phenomenon as I was playing normally. I saw you wrote this on a different thread as well. I included this issue in my reddit guide as well for those who are willing to read the whole guide completely. I had to go through a lot of trial and error so that others don't have to go through what I did.
I wrote a patch for Interstate '76 a while back. Extra steps would be needed to get music working with GOG version though. GOG version comes with a wrapper that is supposed to emulate CD audio - it plays the music from MP3s instead, but the wrapper is poorly written and instead of fixing the wrapper, GOG slapped some ugly hacks in i76.exe to make music somehow work, but still doesn't work properly; same track is not supposed to loop over and over.

Anyway, whoever bothers to learn how to use DxWnd's virtual CD audio feature, will be able to get music working properly the way it was intended with the help of my patch.

It also contains a number of bugfixes and while not perfect, it's still better than unpatched game. Take it or leave it.
avatar
UCyborg: I wrote a patch for Interstate '76 a while back. Extra steps would be needed to get music working with GOG version though. GOG version comes with a wrapper that is supposed to emulate CD audio - it plays the music from MP3s instead, but the wrapper is poorly written and instead of fixing the wrapper, GOG slapped some ugly hacks in i76.exe to make music somehow work, but still doesn't work properly; same track is not supposed to loop over and over.

Anyway, whoever bothers to learn how to use DxWnd's virtual CD audio feature, will be able to get music working properly the way it was intended with the help of my patch.

It also contains a number of bugfixes and while not perfect, it's still better than unpatched game. Take it or leave it.
I used your patch and I have come to the conclusion that is the superior version. The one I had in my guide with 25 fps was showing lots of problems. But with the game at 20 fps and the other files you included did make the game much more enjoyable despite sacrificing the fact no music plays at all anymore. But I will accept that knowing the game is more stable and the gameplay is working properly. I edited my guide accordingly now.
You can use DxWnd to get music playback; need to toggle Expert mode in the Options menu and add a profile for the game with the options Virtual CD audio and Emulate CD pause capability enabled on the Sound tab.

Finally, the MP3 files in the Music folder where the game is installed must be named like:

Track02.mp3
Track03.mp3
Track04.mp3
...
Post edited November 13, 2019 by UCyborg
Does anyone know how to solve this menu issue? It's very laggy, hovering any menu button is nearly impossible. However, if you manage to start the game in any way, it works fine (Glide + D3D).
Attachments:
Post edited December 05, 2019 by Mr.Blade
Game is playable on Win10 64 Bit so far, using dgvoodoo 2.51.

Yet, after mission 3 the game freezes when I click on "accept" in the menu. I just hear "got it", but nothing happens further.
Reloading doesn't help here.

Seems to be a sound issue?

I tested all compatibility modes, nothing helps here.




avatar
Mr.Blade: Does anyone know how to solve this menu issue? It's very laggy, hovering any menu button is nearly impossible. However, if you manage to start the game in any way, it works fine (Glide + D3D).
I once got this broken menu, too. But now I use the following settings, menu and gameplay is fine so far:

- .exe with -glide
- dgVoodoo 2.51
- overwrite all the old files in the folder
- glide settings: Voodoo Rush, 2MB Memory Size (more causes texture problems), 1920 x 1080, 8x MSAA, Force bilinear filter

Try that out!

But me game still crashes / freezes (see above)
Post edited December 05, 2019 by Good4Games2019
This game is a nightmare!

I can't believe how much time I have sunk into getting this game to work. When I first started it wasn't perfect, but at least I was able to enjoy playing it. Then came Scene 5! No matter what I did I couldn't make the jump at the end. Since then I started looking at videos showing much better graphics and, supposedly, stable game play. I just finished a ridiculously complicated "fix". The graphics look much better but there are graphical glitches where everything suddenly looks like someone vomited colors all over the game world. This was tolerable at this point because if you just hit escape to go to the menu and then go back into the game it goes back to normal. Then I noticed the menu problem. When you go into the menu, especially at the end of a scene, the game locks completely and you can't even use task manager to end task. I have to logout through task manager to close the game. The worst part of all is that I can finally make the jump and complete scene 5, but I can't save it!
avatar
Good4Games2019: Game is playable on Win10 64 Bit so far, using dgvoodoo 2.51.

Yet, after mission 3 the game freezes when I click on "accept" in the menu. I just hear "got it", but nothing happens further.
Reloading doesn't help here.

Seems to be a sound issue?

I tested all compatibility modes, nothing helps here.

avatar
Mr.Blade: Does anyone know how to solve this menu issue? It's very laggy, hovering any menu button is nearly impossible. However, if you manage to start the game in any way, it works fine (Glide + D3D).
avatar
Good4Games2019: I once got this broken menu, too. But now I use the following settings, menu and gameplay is fine so far:

- .exe with -glide
- dgVoodoo 2.51
- overwrite all the old files in the folder
- glide settings: Voodoo Rush, 2MB Memory Size (more causes texture problems), 1920 x 1080, 8x MSAA, Force bilinear filter

Try that out!

But me game still crashes / freezes (see above)
Thanks for your reply. With dgVoodoo 2.51 the game does not launch at all: "Failed to initialize 3D hardware acceleration".

But I solved the issue with the menu: Just delete ddraw.dll in the game directory. This apparently is contained in the patch.

Cheers
Furthermore: Would it be possible to create a German version of Interstate '76? I still have the original game discs.

I suppose that the language files are contained in the I76.ZFS

Copying this into the game directory does not work however. The game will not launch. But it could also be related to the fact that I only own the normal edition. I never had the "gold version".

The menu can be translated easily: Just copy DATABASE.MW2 from the game disc and it's in your game disc's language.
avatar
UCyborg: You can use DxWnd to get music playback; need to toggle Expert mode in the Options menu and add a profile for the game with the options Virtual CD audio and Emulate CD pause capability enabled on the Sound tab.

Finally, the MP3 files in the Music folder where the game is installed must be named like:

Track02.mp3
Track03.mp3
Track04.mp3
...
Anyone who values their sanity, don't bother with this godforsaken, over-complicated, hilariously un-user friendly pile of shit excuse of a program. I did this down to a T and it still wouldn't play any music, on top of that, in every graphics rendering backend related tab, I could find no way to get the game to launch through DGVoodoo running in Glide, it would boot in fuck ugly software mode every time.
Use _inmm for music playback, it makes the "loop the first track in the music folder over and over after playing the map/mission specific track once" bug return but it's a fuck of a lot better than dealing with DXWnd.
Annnnd now after accidentally clicking the i76.exe in a Previous Versions Windows backup of my i76 folder, inmm now won't play music on the "Tombstone" auto melee map and keeps looking for a "Track 1", even if I copy one of the songs, name it that, and add it to the .ini. Fucking wonderful.
Post edited May 05, 2020 by MoYomma
Windowed mode (Software Renderer):
Attached is my DxWnd config file for you to try, you have only to change the path to the game clicking on Modify to change it.
I also uploaded a copy of the executable files for my game patched up, no game copyrighted assets here, so this link does not contain piracy material, it's only the executables and files in the game's root directory (no music, no maps, no graphics in this)
Given the "nightmare" that it is to get this game running, this should provide an easier kickstart for people that want to enjoy the game hassle-free.
LINK HERE
Download size: 4MB

I was also able to Extract and Re-Compress the SMK Smacker movie files for those interested in keeping an install of the game without movies, for those who already finished the game. It's possible to make the game's directory as low as 150MB with this. (if you also replace the music files with empty mp3 files) Check the other thread I created for the Smacker video codec files.
It's interesting to notice that my default retain GOG version was throwing errors after installing, I could not run the game. But the fanmade patch EXE worked without hesitation.
Post edited June 17, 2020 by FeelingShred
avatar
timotaka: After trying various different configuration, I've settled on Glide using dgVoodoo in windowed mode. The biggest problem I have encountered with this is that if I set it to high resolution and have the Direct3D set up, the game menus are almost completely unusable. The main menu only seems to refresh (and thus show the current location of the mouse pointer) when I manage to hover over a selection.
I have this same exact problem. Any help is most welcome!