It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm on Windows 7 64-bit, using the Nglide wrapper (had to get full screen), and during the game I'm getting like 2 or 3 frames per second....but when I go to menues it runs flawless.

So ir`s gotta be some issue with 3dfx. I`m on a laptop with radeaon hd 3510.

I`ve tried running it in every compatability mode but it doesn`t seem to matter.
Try turning off Starfield Blur in the options - it's known to cause exactly that problem.