It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So, the game seems to install, re-install and run just fine -- I can watch the opening cut scene and get to what I assume should be the main menu (it's been a long time since I played this game at release)... only, there's nothing there other the cursor and the rotating head of the main character as a child. As nice as this is , I feel like there should be some sort of "play the game" option. Also, the only way I can quit is by using ALT-TAB and closing the game from there. This seems wrong. So, any ideas what's up?

I'm running windows 7 64 bit, FYI. No idea if that matters. <shrug>
This question / problem has been solved by Strijkboutimage
Try running the game in windows XP compatibility mode.
Good idea, but no dice. Also tried it as admin. =(
Awesome, thanks so much for pointing me in the right direction! Time to buy myself a joystick and become the space pirate I born to be.

Also... was that topic really right there the whole time? Boy, do I feel stupid! =)